ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Package 'sbcl' has no installation candidate

asked 2015-02-06 11:08:56 -0500

T-R0D gravatar image

I am trying to install ROS hydro bare bones on a Samsung Chromebook that is in developer mode. This means that I am using an ARM form of Ubuntu (with the xfce desktop environment, if that matters). All of my packages thus far have downloaded with the "armhf" suffix, which I gather is preferable to "armel".

Using the official installation from source instructions for ROS hydro (here), when running the bash command:

rosdep install --from-paths src --ignore-src --rosdistro hydro -y

most of the packages install without issue. However, I get the error:

$ E: Package 'sbcl' has no installation candidate

A suggestion from the terminal output is to install some other things:

$ ...
$ However the following packages replace it:
$  sbcl-source sbcl-doc

so I installed them with

sudo apt-get install sbcl-source sbcl-doc

I still get the same error as above, so I installed sbcl from source using the Linux armhf tarball and the instructions from SBCL's site. The installation was successful (I can invoke sbcl from the command line), but the ROS install still fails (when I run the first bash command I listed).

So, after a long description of my steps, my question is: Is there any way around this? I clearly have SBCL, so am I safe in assuming that ROS packages that depend on it will run fine, and really I just need the ROS installer to skip this step?

Other solutions I've seen just say to delete the sbcl directory in the src file, but I am hesitant to just do that since I don't know if I will need it and my system can install SBCL

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-02-07 02:15:15 -0500

ahendrix gravatar image

On older versions of Ubuntu, SBCL is not available as a package.

ROS uses the package manager (apt) to detect and install dependencies.

Since you've installed SBCL outside of the package manager, rosdep isn't aware that SBCL is installed. I believe rosdep has an option to skip specific keys; you should consult the help options for rosdep, add the option to skip the sbcl key, and continue with your installation.

If your specific version of Ubuntu is supported by the UbuntuARM packages, you should use those instead; you will save a significant amount of time installing and compiling things, and the dependency issues have already been figured out and supplied for you. (in the case of SBCL on older versions of Ubuntu, I patched ROS to remove the lisp bindings and the dependency on SBCL completely).

edit flag offensive delete link more



Thanks! I re-ran the rosdep install... command with the --skip-keys='sbcl' option and it seems to have worked out. I did not try anything with UbuntuARM packages since it seems I could get by without doing so, but for future readers, that looks like a good option.

T-R0D gravatar image T-R0D  ( 2015-02-09 11:06:10 -0500 )edit

Question Tools

1 follower


Asked: 2015-02-06 11:08:56 -0500

Seen: 993 times

Last updated: Feb 07 '15