Ask Your Question
3

Problem with YAML when compiling Camera_Calibration_Parsers

asked 2013-05-31 15:28:49 -0500

orion gravatar image

updated 2014-01-28 17:16:43 -0500

ngrennan gravatar image

I am currently having a problem with compiling Camera_Calibration_Parsers (error) for Groovy. I am working with an ARM processor and building from source. There isn't a libyaml-cpp-dev or yaml-cpp-dev binary available from apt-get so I am attempting an install from source. I have tried many ways on my own as well as trying to follow this.

I have also confirmed having the share libraries option selected for CMake.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
3

answered 2013-06-03 04:41:14 -0500

orion gravatar image

The solution I found was a combination of installing yaml-cpp-0.3.0 from source (which I already did) and removing the pre-built components of camera_calibration_parser (which I did not).

First, when installing yaml-cpp-0.3.0, make sure you open the configuration of the CMake file (i.e. run "ccmake .." in the build directory). Turn the option "BUILD_SHARED_LIBS" ON.

Second, navigate to the "build_isolated" folder under ros/groovy. Remove the camera_calibration_parser folder. Then you are safe to rebuild it.

As a note, the error was not only related to the "GetType" function. There were other times that different functions in yaml-cpp caused the error.

Hope this helps anyone who comes across this problem.

edit flag offensive delete link more

Comments

Thanks so much, I was struggling with this issue and didn't think to remove the pre-built components!

AndrewLawson gravatar imageAndrewLawson ( 2014-03-10 10:34:43 -0500 )edit
2

answered 2013-06-01 12:42:43 -0500

Artem gravatar image

Check what version of yaml-cpp is installed in your system. If it's 0.5.0 you will have troubles compiling camera_calibration_paser. Try to downgrade to yaml-cpp to 0.3.0.

edit flag offensive delete link more

Comments

There is a binary of yaml-cpp that is installable and does so when I try to apt-get camera_calibration_parser. It is 0.2.7. I have tried to install 0.2.5, 0.2.6, 0.2.7, 0.3.0, and 0.5.0 with no luck. In the process I did make sure to uninstall the apt-get version. There are no -dev versions.

orion gravatar imageorion ( 2013-06-01 15:10:17 -0500 )edit

Thanks for the help. Finally figured out what my simple issue was.

orion gravatar imageorion ( 2013-06-03 04:42:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-05-31 15:28:49 -0500

Seen: 357 times

Last updated: Jun 03 '13