Ask Your Question
0

Problem with Beginner Tutorials #17 [closed]

asked 2015-02-05 03:52:21 -0600

pexison gravatar image

Hi, when I try to use the command rosbag record -a, it gives me this output:

robot@ASHROCK:~/bagfiles$ rosbag record -a /opt/ros/hydro/lib/rosbag/record: symbol lookup error: /opt/ros/hydro/lib/librosbag.so: undefined symbol:
_ZN3ros7console5printEPNS0_10FilterBaseEPN7log4cxx6LoggerENS0_6levels5LevelEPKciS9_S9_z

What is this error and what can I do to fix it?

Thanks!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by pexison
close date 2015-02-05 05:40:29.796049

Comments

1

Did you install ros desktop full?

BennyRe gravatar imageBennyRe ( 2015-02-05 05:28:09 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-02-05 05:40:15 -0600

pexison gravatar image
sudo apt-get dist-upgrade

was the solution.

edit flag offensive delete link more

Comments

Please mark your answer as correct.

BennyRe gravatar imageBennyRe ( 2015-02-05 09:25:24 -0600 )edit

It says that >25 points required to accept or unaccept your own answer

pexison gravatar imagepexison ( 2015-02-05 10:47:07 -0600 )edit
1

Oh sorry I always forget this restriction. Now you have enough karma.

BennyRe gravatar imageBennyRe ( 2015-02-06 04:20:37 -0600 )edit

I hope that this is good karma :)

pexison gravatar imagepexison ( 2015-02-06 04:42:25 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-02-05 03:52:21 -0600

Seen: 65 times

Last updated: Feb 05 '15