Ask Your Question
0

raspberry pi use

asked 2015-01-31 14:01:40 -0600

Gulfboy64 gravatar image

has anyone loaded the ROS package on a Raspberry Pi?

edit retag flag offensive close merge delete

Comments

I am currently in the process of loading Indigo on the Raspberry Pi, to use with an iRobot Create 2. Wish me luck.

rzwemer gravatar imagerzwemer ( 2015-01-31 15:21:49 -0600 )edit

how does your iCreate2 feel. I'm very interested in this device.

Chrimo gravatar imageChrimo ( 2015-02-02 10:29:46 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2015-02-02 17:25:49 -0600

Freyr gravatar image

I followed the indigo ROS raspberry pi tutorial from the wiki with my B+ and it is working pretty good so far. I have been avoiding running the desktop and operate in command line via SSH (putty) using wifi.

As mentioned the Raspberry Pi 2 is out now at the same price point with an ARM7 architecture. A member of the ROS community has been working on ready packages for the ARM7 but there are currently no plans for ARM6 support that I know of. Building from source works for most of the part thought but it takes a while.

edit flag offensive delete link more

Comments

I have tried using this same tutorial, but get error finding the ROS distros? Has the distro been moved?

Gulfboy64 gravatar imageGulfboy64 ( 2015-02-03 14:28:19 -0600 )edit

Worked for me pretty much as is. I stuck to the ros-comm package to save build time mostly and that worked fined. Are you using the vanilla Raspbian Wheezy image as base? Most of the actual ROS packages are build locally. Could you point to the actual part/line where the install failed?

Freyr gravatar imageFreyr ( 2015-02-04 15:52:12 -0600 )edit
0

answered 2015-02-02 10:28:02 -0600

Chrimo gravatar image

Succeed ?

Raspi+MPU is not well supported and slow... I's prefer Create2 + Odroid C1 and plain Ubuntu 14.04 ARM...

New Raspi2 will do the same because this new board uses ARM7 cores (4)

edit flag offensive delete link more
0

answered 2015-02-02 14:12:08 -0600

corb gravatar image

RPI will likely be too slow and not enough memory. Either Odroid C1 or just announced new Rpi would be better

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-01-31 14:01:40 -0600

Seen: 234 times

Last updated: Feb 02 '15