Timeout Error for Hokuyo Node with URG-04LX-UG01 Sensor [closed]

asked 2015-01-29 13:47:54 -0600

atp gravatar image

updated 2015-01-31 14:55:50 -0600

I'm using Ubuntu 12.04 with ROS Hydro , and seeing the same error as: http://answers.ros.org/question/45850... :

>> rosrun hokuyo_node hokuyo_node _port:=/dev/ttyACM0
[ERROR] [1422560559.586392534]: Exception thrown while opening Hokuyo.
timeout reached (in hokuyo::laser::laserReadline) You may find further details at http://www.ros.org/wiki/hokuyo_node/Troubleshooting

I think I do have the correct permissions on /dev/ttyACM0 since:

>> ls -l /dev/ttyACM*B0
crwxrwxrwx 1 root dialout 166, 0 Jan 29 14:42 /dev/ttyACM0

Solution: Use a different USB cable.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by atp
close date 2015-01-31 14:55:09.849233

Comments

Do you actually need the _ in your parameter name? ie port instead of _port? ref: http://wiki.ros.org/hokuyo_node/Tutor... the parameters for portname is port

PeterMilani gravatar image PeterMilani  ( 2015-01-30 03:51:17 -0600 )edit

I don't think so. Also, the same error occurs when I run:

rosrun hokuyo_node getID /dev/ttyACM0

atp gravatar image atp  ( 2015-01-30 11:16:46 -0600 )edit