Ask Your Question
0

Could you please help me understand the error log?

asked 2015-01-27 06:32:20 -0500

ShirishDROS gravatar image

updated 2015-01-27 09:25:36 -0500

gvdhoorn gravatar image

Hi everyone, I am completely new to ROS or any distribution computing system for that matter. I was working with my tutorials from class. When I tried to build using catkin_make, I encountered an error. Since I have never worked with ROS before, I don't understand what the error log says, thus have no idea what the root of the error is. Could someone kindly tell me why the error has occurred and how could I solve it?

Here's the error that occurs.

-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- ~~  traversing 5 packages in topological order:
-- ~~  - beginner_tutorials
-- ~~  - daisya_euslisp_tutorials
-- ~~  - dynamixel_7dof_arm
-- ~~  - turtleboteus
-- ~~  - dxl_armed_turtlebot
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- +++ processing catkin package: 'beginner_tutorials'
-- ==> add_subdirectory(beginner_tutorials)
[roseus.camke] Loading... PROJECT_NAME=beginner_tutorials USE_ROSBILD=
-- Using these message generators: gencpp;geneus;genlisp;genpy
CMake Error at /opt/ros/hydro/share/catkin/cmake/assert.cmake:20 (message):


  Assertion failed: file
  '/home/mechuser/catkin_ws/src/beginner_tutorials/action/DoDishes.action'
  does not exist.  Message: action file not found

Call Stack (most recent call first):
  /opt/ros/hydro/share/actionlib_msgs/cmake/actionlib_msgs-extras.cmake:35 (assert_file_exists)
  beginner_tutorials/CMakeLists.txt:66 (add_action_files)


-- Configuring incomplete, errors occurred!
make: *** [cmake_check_build_system] エラー 1
Invoking "make cmake_check_build_system" failed

Thanks in advanced for you help. Shirish

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-01-27 14:49:52 -0500

This error is telling you that the file /home/mechuser/catkin_ws/src/beginner_tutorials/action/DoDishes.action doesn't exist. Does it? If it does, are the permissions correct (owned by you)?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-27 06:32:20 -0500

Seen: 394 times

Last updated: Jan 27 '15