Ask Your Question
0

Unable to install libopenni2-dev

asked 2015-01-26 02:26:31 -0500

Xin gravatar image

Hi, I am using Odroid XU3(Arm Processor), Ubuntu 12.04(Precise) and ROS(Hydro). When I try to build my OpenNI2_camera, I got these error

-- checking for module 'libopenni2' -- package 'libopenni2' not found -- checking for module 'openni2' -- package 'openni2' not found

Than I found out that installing libopenni2-dev will solve the problem, but when I try to apt-get install, I get these error

Package libopenni2-dev is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'libopenni2-dev' has no installation candidate

I am new these programs, can anyone help me with this problem, Thanks.

edit retag flag offensive close merge delete

Comments

I think I need a PPA to source for libopenni2-dev for Arm processor.

Xin gravatar image Xin  ( 2015-01-26 03:27:27 -0500 )edit

Did you get this working? Im having the same error?

miguel gravatar image miguel  ( 2015-08-15 04:42:25 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-02-02 16:23:33 -0500

130s gravatar image

Not sure about the history, but I found the binary repositories of libopenni2-dev has been migrated from ros.org to ubuntu.com .

On my Trusty

$ apt-cache policy libopenni2-dev
libopenni2-dev:
  Installed: 2.2.0.33+dfsg-1~ubuntu14.04.1
  Candidate: 2.2.0.33+dfsg-1~ubuntu14.04.1
  Version table:
 *** 2.2.0.33+dfsg-1~ubuntu14.04.1 0
        500 http://packages.ros.org/ros-shadow-fixed/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

Xenial

$ apt-cache policy libopenni2-dev
libopenni2-dev:
  Installed: 2.2.0.33+dfsg-6
  Candidate: 2.2.0.33+dfsg-6
  Version table:
 *** 2.2.0.33+dfsg-6 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        100 /var/lib/dpkg/status

Thus, OP was on Hydro then, make sure you specify ros.org as a source list, something like this for your distro.

Also OP was on ARM. I doubt there was a binary build for openni2* packages for ARM on Hydro. In ROS Indigo there is (and going onward I assume).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-26 02:26:31 -0500

Seen: 882 times

Last updated: Feb 02 '18