ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Orocos-bfl not found while installing navigation stack ROS indigo + Ubuntu 14.04

asked 2015-01-23 14:32:38 -0500

Naman gravatar image

Hey guys,

I have just installed Ubuntu 14.04 and ROS indigo and is trying to install navigation stack ( ). While doing catkin_make, I get the following error in the robot_pose_ekf package:

-- Boost version: 1.54.0
-- +++ processing catkin package: 'robot_pose_ekf'
-- ==> add_subdirectory(navigation/robot_pose_ekf)
checking for module 'orocos-bfl'
-- package 'orocos-bfl' not found
CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:283 (message):
A required package was not found
Call Stack (most recent call first):
/usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:337 (_pkg_check_modules_internal)
navigation/robot_pose_ekf/CMakeLists.txt:6 (pkg_check_modules)

Then, I tried to install bfl from which did not work as it is not up-to-date I guess. Can anyone help me out here and give some suggestions on how to solve this issue?

Thanks in advance.
Naman Kumar

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2015-01-23 16:10:24 -0500

ahendrix gravatar image

Try installing the binary version of the navigation stack:

sudo apt-get install ros-indigo-navigation
edit flag offensive delete link more


Thanks..this worked but I want to install the navigation stack in my workspace so that I can work on it and modify it whereas this installs in opt/ros/indigo.. any suggestions regarding this?

Naman gravatar image Naman  ( 2015-01-24 18:22:50 -0500 )edit

Once you've installed the binary of navigation, you'll have bfl (since ros-indigo-ocoros-bfl will have been installed as a dependency of navigation), so you should now find that your workspace builds.

fergs gravatar image fergs  ( 2015-01-24 22:50:27 -0500 )edit

Yep.. that worked.. Thanks!! :)

Naman gravatar image Naman  ( 2015-01-26 16:10:51 -0500 )edit

sudo apt-get install ros-indigo-navigation does not work. Any suggestions? Cannot also do rosdep install --from-paths src --ignore-src --rosdistro indigo -y

engineerdream gravatar image engineerdream  ( 2018-03-09 19:57:20 -0500 )edit

answered 2020-04-15 04:24:22 -0500

puwanan gravatar image

Please try

sudo apt-get install ros-indigo-bfl

edit flag offensive delete link more

answered 2015-01-24 22:52:58 -0500

fergs gravatar image

BFL is a third party library, and is best installed via the debian package that is released. In order to get all dependencies installed before starting to build your workspace, you can use rosdep. In the top-level folder of your workspace (that is, the folder with src, devel, build folders), you can run:

rosdep install --from-paths src --ignore-src --rosdistro indigo -y

This will use rosdep to determine what to install to meet the dependencies of all the source packages that are to be built in your workspace.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-01-23 14:32:38 -0500

Seen: 11,663 times

Last updated: Jan 24 '15