Nao installation - problem with python [ArchLinux]

asked 2015-01-11 11:44:44 -0600

willtd gravatar image

I'm following the official guide http://wiki.ros.org/nao/Tutorials/Get... to install Nao. The problem that I'm running into is when I tried to start the ros_driver package by executing :

$ LD_LIBRARY_PATH=~/naoqi/naoqi-sdk-1.12.3-linux32/lib:$LD_LIBRARY_PATH NAO_IP=127.0.0.1 roslaunch nao_driver nao_driver_sim.launch

I'd get the following output: Traceback (most recent call last): File "/opt/ros/indigo/bin/roslaunch", line 34, in <module> import roslaunch File "/opt/ros/indigo/lib/python2.7/site-packages/roslaunch/__init__.py", line 38, in <module> import logging File "/usr/lib/python2.7/logging/__init__.py", line 26, in <module> import sys, os, time, cStringIO, traceback, warnings, weakref, collections File "/usr/lib/python2.7/collections.py", line 9, in <module> from operator import itemgetter as _itemgetter, eq as _eq ImportError: /usr/lib/python2.7/lib-dynload/operator.so: undefined symbol: _PyUnicodeUCS4_AsDefaultEncodedString

From my understanding, the _PyUnicodeUCS4_AsDefaultEncodedString is related to my built python USC version. Because it says UCS4, my Python indicates to be built in another version, hence USC2.

But when I tried to verify my python USC with: sys.maxunicode

I'd get the return value of 1114111 which is the value of USC4.

I'm lost right now and don't know where to go from here. Any help would be appreciated!

edit retag flag offensive close merge delete