Ask Your Question
0

Problems with robotino_node when using roslaunch

asked 2014-12-26 09:27:21 -0500

sam3891 gravatar image

updated 2014-12-29 10:58:42 -0500

130s gravatar image

Hello,

When I run roslaunch robotino_node robotino_node.launch, I get the following output which indicates that robotino_node & robotino_odometry_node are missing (when I look in robotino-ros-pkg/robotino_node/bin, there too they are missing):

SUMMARY
========

PARAMETERS
 * /robot_description: <?xml version="1....
 * /robot_state_publisher/publish_frequency: 20.0
 * /robotino_camera_node/cameraNumber: 0
 * /robotino_camera_node/hostname: 172.26.1.1
 * /robotino_laserrangefinder_node/hostname: 172.26.1.1
 * /robotino_laserrangefinder_node/laserRangeFinderNumber: 0

 * /robotino_mapping_node/hostname: 172.26.1.1
 * /robotino_node/downsample_kinect: True
 * /robotino_node/hostname: 172.26.1.1
 * /robotino_node/leaf_size_kinect: 0.04
 * /robotino_node/max_angular_vel: 3.0
 * /robotino_node/max_linear_vel: 0.5
 * /robotino_node/min_angular_vel: 0.1
 * /robotino_node/min_linear_vel: 0.05
 * /robotino_odometry_node/hostname: 172.26.1.1
 * /rosdistro: indigo
 * /rosversion: 1.11.9

NODES
  /
    robot_state_publisher (robot_state_publisher/state_publisher)
    robotino_camera_node (robotino_node/robotino_camera_node)
    robotino_laserrangefinder_node (robotino_node/robotino_laserrangefinder_node)
    robotino_mapping_node (robotino_node/robotino_mapping_node)
    robotino_node (robotino_node/robotino_node)
    robotino_odometry_node (robotino_node/robotino_odometry_node)

auto-starting new master
process[master]: started with pid [11321]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 10ff797c-8d13-11e4-8424-001e6537844e
process[rosout-1]: started with pid [11334]
started core service [/rosout]
ERROR: cannot launch node of type [robotino_node/robotino_node]: can't locate node [robotino_node] in package [robotino_node]
ERROR: cannot launch node of type [robotino_node/robotino_odometry_node]: can't locate node [robotino_odometry_node] in package [robotino_node]
process[robotino_laserrangefinder_node-4]: started with pid [11351]
process[robotino_camera_node-5]: started with pid [11368]
process[robot_state_publisher-6]: started with pid [11380]
/opt/ros/indigo/lib/robot_state_publisher/state_publisher
[ WARN] [1419607376.930340318]: The 'state_publisher' executable is deprecated. Please use 'robot_state_publisher' instead
[ WARN] [1419607376.934934125]: The root link base_link has an inertia specified in the URDF, but KDL does not support a root link with an inertia.  As a workaround, you can add an extra dummy link to your URDF.
rocess[robotino_mapping_node-7]: started with pid [11418]
[ INFO] [1419607378.754853544]: LaserRangeFinder0 disconnected from Robotino.
[ INFO] [1419607379.158983565]: Mapping disconnected from Robotino.
[ INFO] [1419607379.495352459]: Camera0 disconnected from Robotino.

Can someone help?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-01-07 08:48:27 -0500

sam3891 gravatar image

updated 2015-01-07 08:49:13 -0500

I had checked out robotino-ros-pkg from svn and run 'rosmake robotino'. This is when I got the aforementioned error. But I managed to solve it by excluding all occurrences of KinectROS.cpp which was causing the problems. So now when i run 'rosmake robotino', it generates all executables.

edit flag offensive delete link more
1

answered 2014-12-29 11:36:45 -0500

130s gravatar image

Being able to launch a .launch file indicates that your package is most likely correctly referenced by roslaunch. So next I suspect the node executable doesn't exist (yet). If the target executable is written in:

  • C++: you might have to build. Have you built your package? E.g. http://wiki.ros.org/ROS/Tutorials/Bui...
  • Python: See its mode by e.g. ls -l %TARGET_NODE_FILE% and if not set as executable then do chmod.

HTH.

edit flag offensive delete link more

Comments

I haven't built the package as you have written it, that is because I used "rosmake" and it is supposed to build all the packages isn't it? And in any case, robotino_camera_node, laserrangefinder_node and mapping_node got automatically built so why not robotino_node and odometry_node?

sam3891 gravatar image sam3891  ( 2015-01-02 12:40:51 -0500 )edit

I suggest you edit your question to add more detail (e.g. all the commands and output of when you build the packages). Otherwise it's hard for us to give help since there's only limited amount of info provided.

130s gravatar image 130s  ( 2015-01-03 21:12:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-12-26 09:27:21 -0500

Seen: 1,705 times

Last updated: Dec 29 '14