Ask Your Question
1

Unable to setup sources.list ARM [closed]

asked 2014-12-12 22:52:07 -0500

l0g1x gravatar image

Hey was just wondering if anyone had noticed that the link on install indigo on ARM has a bad URL when trying to add the ros repo to the sources.list .

sudo sh -c 'echo "deb http://packages.namniart.com/repos/ros trusty main" > /etc/apt/sources.list.d/ros-latest.list'

Thats the line i copied, and i was getting this error when trying to wget the key:

ubuntu@tegra-ubuntu:~$ wget http://packages.namniart.com/repos/namniart.key -O - | sudo apt-key add -
--2014-12-12 22:26:29--  http://packages.namniart.com/repos/namniart.key
Resolving packages.namniart.com (packages.namniart.com)... failed: Name or service not known.
wget: unable to resolve host address ‘packages.namniart.com’
gpg: no valid OpenPGP data found.
ubuntu@tegra-ubuntu:~$ sudo apt-get update
Err http://packages.namniart.com trusty InRelease

Err http://packages.namniart.com trusty Release.gpg
Could not resolve 'packages.namniart.com'
Ign http://ports.ubuntu.com trusty InRelease       
Ign http://ports.ubuntu.com trusty-updates InRelease

I tried on my desktop to see if maybe it was something on my jetson, but i couldnt even just get to packages.namniart.com through my browser.

Anybody know if this is just maintenance?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by l0g1x
close date 2015-04-02 21:51:35.475023

Comments

I have the same problem since yesterday, anybody have a solution?

dusko_mk gravatar image dusko_mk  ( 2014-12-13 09:43:23 -0500 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2014-12-13 13:44:22 -0500

ahendrix gravatar image

Sorry; I'm doing some maintenance on my packages server. It should be back online in a few days.

edit flag offensive delete link more
0

answered 2014-12-15 01:05:17 -0500

Good day, I get the error that domain has expired.Are you planning to move on another domain? I m under pressure for a new ROS project using arm.

Does anyone knows another mirror?

edit flag offensive delete link more

Comments

I'm working on renewing the domain. It should be back up online in a few days.

ahendrix gravatar image ahendrix  ( 2014-12-15 02:22:17 -0500 )edit

Thank you for the feedback.

korniza gravatar image korniza  ( 2014-12-15 02:44:23 -0500 )edit
1

I've renewed the domain and the DNS records are updated. It may take up to 24 hours for the DNS changes to propagate.

ahendrix gravatar image ahendrix  ( 2014-12-17 13:16:09 -0500 )edit

Thanks for the feedback but I still get the same problem when running wget.

MarcoB gravatar image MarcoB  ( 2014-12-22 03:20:15 -0500 )edit

@MarcoB: it works for me. Are you sure your board has an internet connection? Are you able to view http://packages.namniart.com in your browser? You may want to ask a new question, because I suspect your issue isn't related to my DNS expiring and being renewed.

ahendrix gravatar image ahendrix  ( 2014-12-22 04:21:15 -0500 )edit

Indeed, I cecked and it was a connection problem, now it works fine. Thank you very much for your work.

MarcoB gravatar image MarcoB  ( 2014-12-22 04:50:03 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2014-12-12 22:52:07 -0500

Seen: 536 times

Last updated: Dec 13 '14