Ask Your Question
0

error run teleop_twist_keyboard package

asked 2014-12-12 07:33:51 -0500

ksmksam gravatar image

updated 2014-12-12 13:37:53 -0500

ahendrix gravatar image

i install packge from

https://github.com/ros-teleop/teleop_...

and when i run this rosrun teleop_twist_keyboard teleop_twist_keyboard.py ihave this erorr

~$ rosrun teleop_twist_keyboard teleop_twist_keyboard.py
[rospack] Error: package 'teleop_twist_keyboard' not found
edit retag flag offensive close merge delete

Comments

1

please specify ROS distro you are using. Did you install the package inside your ros workspace and then sourced the setup.bash properly? Check again. you should run $ source ~/your_ros_worskpace/devel/setup.bash after you run the catkin_make command to source properly.

AlexR gravatar image AlexR  ( 2014-12-12 08:10:57 -0500 )edit

indigo ros and idont know how sourced the setup.bash

ksmksam gravatar image ksmksam  ( 2014-12-12 08:29:18 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2014-12-13 01:07:43 -0500

AlexR gravatar image

updated 2014-12-13 13:44:55 -0500

ahendrix gravatar image

I assume you followed the instructions for setting up your ROS environment tutorial. You need to download the teleop_twist_keyboard from the github to your ~/catkin_ws/src folder. Steps:

1) cd ~/catkin_ws/src

2) git clone https://github.com/ros-teleop/teleop_twist_keyboard

3) cd ~/catkin_ws

4) catkin_make

5) source ~/catkin_ws/devel/setup.bash

6) source ~/.bashrc

I also assume you have your ros environment in your bashrc file. It should contain the following lines : source /opt/ros/indigo/setup.bash and you should add the following lines to your bashrc script by running :

gedit ~/.bashrc and add :

 source ~/catkin_ws/devel/setup.bash

New terminals will pick up when you open it. Also, you will need to remap linear and angular velocity for your robot to the /cmd_vel topic to use the keyboard for teleoperation. I would suggest looking into turtlebot_teleop package for details.

edit flag offensive delete link more

Comments

1

I've removed the sudo for editing your bashrc. If you need sudo to edit your bashrc, the ownership or permissions are wrong, and you should fix them instead of editing your bashrc with sudo. Do: sudo chown $USER:$USER ~/.bashrc and chmod 644 ~/.bashrc

ahendrix gravatar image ahendrix  ( 2014-12-13 13:47:32 -0500 )edit

@ahendrix I did not knew that. I always use the sudo to edit my bashrc. Good suggestion though thanks.

AlexR gravatar image AlexR  ( 2014-12-14 06:50:55 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-12-12 07:33:51 -0500

Seen: 4,254 times

Last updated: Dec 13 '14