Ask Your Question
1

dynamixel no motor found

asked 2014-12-03 18:27:01 -0500

pavi.hmd gravatar image

i had connected OpenCM9.04 with MX-64 motors. tried this dynamixel tutorial.after this step,

roslaunch my_dynamixel_tutorial controller_manager.launch

i get this error:

SUMMARY
========

PARAMETERS
 * /dynamixel_manager/namespace: dxl_manager
 * /dynamixel_manager/serial_ports/pan_tilt_port/baud_rate: 57600
 * /dynamixel_manager/serial_ports/pan_tilt_port/max_motor_id: 25
 * /dynamixel_manager/serial_ports/pan_tilt_port/min_motor_id: 1
 * /dynamixel_manager/serial_ports/pan_tilt_port/port_name: /dev/ttyACM0
 * /dynamixel_manager/serial_ports/pan_tilt_port/update_rate: 20
 * /rosdistro: indigo
 * /rosversion: 1.11.9

NODES
  /
    dynamixel_manager (dynamixel_controllers/controller_manager.py)

auto-starting new master
process[master]: started with pid [3297]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 68403748-7b49-11e4-b3a3-ac7289859e59
process[rosout-1]: started with pid [3310]
started core service [/rosout]
process[dynamixel_manager-2]: started with pid [3327]
/opt/ros/indigo/lib/python2.7/dist-packages/dynamixel_driver/dynamixel_serial_proxy.py:92: SyntaxWarning: The publisher should be created with an explicit keyword argument 'queue_size'. Please see http://wiki.ros.org/rospy/Overview/Publishers%20and%20Subscribers for more information.
  self.motor_states_pub = rospy.Publisher('motor_states/%s' % self.port_namespace, MotorStateList)
/opt/ros/indigo/lib/python2.7/dist-packages/dynamixel_driver/dynamixel_serial_proxy.py:93: SyntaxWarning: The publisher should be created with an explicit keyword argument 'queue_size'. Please see http://wiki.ros.org/rospy/Overview/Publishers%20and%20Subscribers for more information.
  self.diagnostics_pub = rospy.Publisher('/diagnostics', DiagnosticArray)
[INFO] [WallTime: 1417651594.990743] pan_tilt_port: Pinging motor IDs 1 through 25...
[FATAL] [WallTime: 1417651597.100174] pan_tilt_port: No motors found.
================================================================================REQUIRED process [dynamixel_manager-2] has died!
process has died [pid 3327, exit code 1, cmd /opt/ros/indigo/lib/dynamixel_controllers/controller_manager.py __name:=dynamixel_manager __log:=/home/pavithran/.ros/log/68403748-7b49-11e4-b3a3-ac7289859e59/dynamixel_manager-2.log].
log file: /home/pavithran/.ros/log/68403748-7b49-11e4-b3a3-ac7289859e59/dynamixel_manager-2*.log
Initiating shutdown!
================================================================================
[dynamixel_manager-2] killing on exit
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

i also tried changing the baudrate to 1000000.

how do i overcome this error?

Thank you...

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-12-04 07:45:29 -0500

Murilo F. M. gravatar image

You did not mention whether you configured the servos, so I thought it'd be worth mentioning.

Each servo stores a set of parameters internally. You must configure (or at least check the configuration of) every servo separately before you attempt to communicate with them.

There are 2 key parameters you must ensure are correct in order to communicate with the servos.

The first parameter is the baud rate. You are trying to connect to the servos at 57600 bps, and you said you also tried 1000000 bps. You must ensure all servos are configured to use the same baud rate, and use that value when you load the node.

The second parameter is the servo ID (which should be unique to each servo). You are attempting to communicate with servos which IDs range from 1 to 25. It could be that your servos were configured with IDs out of this range.

Configuring the servos:

You may use RoboPlus (on Windows), which is the official software from Robotis.

Alternatively (if you know the parameter values currently configured), you can also change the servos IDs, as well as set the desired parameter values using these ROS nodes.

Related question: ClamArm using Dynamixel Motors: No Motors Found

I hope it helps!

edit flag offensive delete link more

Comments

Thanks for the reply. Yes,i configured the servos with baud rate and id . But still no luck. Should i use usb2dynamixel or is OpenCM9.04B enough for this tutorial?

pavi.hmd gravatar imagepavi.hmd ( 2014-12-04 10:18:29 -0500 )edit

I have used the USB2Dynamixel and a simple USB to RS485 converter I assembled myself. They both worked fine for me... :-|

Murilo F. M. gravatar imageMurilo F. M. ( 2014-12-08 14:18:30 -0500 )edit

bad luck, I tried both USb2dynamixel and DIY usb-rs485 converter, no one works for me...... and also roboplus cannot find my mx-64ar through all the bps searching.... is that mean my servo is a defective ?

Wine gravatar imageWine ( 2015-04-01 09:41:25 -0500 )edit

It does sound like your servo might be defective. Have you got another servo to test?

Murilo F. M. gravatar imageMurilo F. M. ( 2015-04-24 03:20:31 -0500 )edit

I have same issue, with arbotix-m controller no motor detected when I run

roslaunch dynamixel_tutorials controller_manager.launch
Abdu gravatar imageAbdu ( 2017-10-15 16:16:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-12-03 18:27:01 -0500

Seen: 1,868 times

Last updated: Dec 04 '14