ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Errors at catkin_make for laser_scan_matcher

asked 2014-11-18 05:32:09 -0500

Victor Gomez gravatar image

Good day everyone,

I'm trying to work with Polar Scan Matcher and Canonical Scan Matcher (laser_scan_matcher) from Scan_tools. So far, I've been able to run the demo.launch for PSM, but not (yet) to use my own LRF. Nevertheless, when trying to use the CSM demo, I receive an error as follows:

ERROR: cannot launch node of type [laser_scan_matcher/laser_scan_matcher_node]: can't locate node [laser_scan_matcher_node] in package [laser_scan_matcher]

Reading, I found out that the problem is because there is no executable ready. I tried once more to do catkin_make (I did it once when installing scan_tools), and pay attention to the output. I found this:

-- Configuring incomplete, errors occurred! See also "/home/antonio/PSM/build/scan_tools/laser_scan_matcher/csm/src/CMakeFiles/CMakeOutput.log". make[2]: *** [scan_tools/laser_scan_matcher/csm/stamp/csm_src-configure] Error 1 make[1]: *** [scan_tools/laser_scan_matcher/CMakeFiles/csm_src.dir/all] Error 2 make: *** [all] Error 2 Invoking "make" failed

I've also tried rosrun laser_scan_matcher and tried to see the options with tab but none appears.

My settings are ROS Indigo in Ubuntu 14.04.

This is what I've got so far with my little knowledge. I hope someone can help me fix this.

Thank you!

edit retag flag offensive close merge delete


Is there a package.xml or a manifest.xml in the package?

dornhege gravatar image dornhege  ( 2014-11-18 06:07:43 -0500 )edit

I just got the demo working on my machine with:

Is this what you did?

Angus gravatar image Angus  ( 2014-11-18 20:05:08 -0500 )edit

@dornhege Yes, the package has its proper xml files thank you!

@Angus Thank you so much, you should have written your post as answer! I missed to install the compiling library. I didn't know about it though. Now it's running and time for some tests using the real thing. Thank you!

Victor Gomez gravatar image Victor Gomez  ( 2014-11-19 03:54:55 -0500 )edit

Awesome! I'll just reply with an answer so we can mark as solved.

Angus gravatar image Angus  ( 2014-11-19 09:07:01 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2014-11-19 09:06:27 -0500

Angus gravatar image

As per the comments, the demo seems to work on Inidigo with these commands:

$ cd [indigo catkin workspace directory]
$ git clone
$ sudo apt-get install libgsl0-dev
$ catkin_make
$ roslaunch laser_scan_matcher demo.launch
edit flag offensive delete link more


The libgs10-dev is the library to compile correctly the package with catkin_make. That was the main problem.

Thank you Angus!

Victor Gomez gravatar image Victor Gomez  ( 2014-11-19 23:21:23 -0500 )edit

Indeed! Installing the libgsl0-dev solved it for me too using the Hydro branch. Thank you =).

Sergio MP gravatar image Sergio MP  ( 2014-12-04 06:15:21 -0500 )edit

It works for me. Thanks for sharing! :)

rosRabbit gravatar image rosRabbit  ( 2015-08-26 00:53:11 -0500 )edit

Works for Kinetic as well

parzival gravatar image parzival  ( 2019-08-13 03:46:21 -0500 )edit

answered 2015-07-13 18:44:53 -0500

130s gravatar image

Slight modification to @Angus' answer as a more systematic, flexible approach:

- $ sudo apt-get install libgsl0-dev
+ $ rosdep install --from-paths src --ignore-src --rosdistro %YOUR_ROS_DISTRO% -r

This rosdep command installs all the missing system dependency (must be described in package.xml) in all the packages in your src directory.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-11-18 05:32:09 -0500

Seen: 3,802 times

Last updated: Jul 13 '15