Ask Your Question
0

disparity image generation using prosilsica camera pair

asked 2014-11-12 11:32:37 -0600

Robot gravatar image

updated 2014-11-12 14:07:50 -0600

ahendrix gravatar image

i have used two prosilica cameras. first i have launched the driver for both the cameras. left driver and right driver. once both the cameras are working i have launched the node stereo_image_proc for generating the disparity image. but the disparity image window is empty. i have checked the topic as well the one which should hold the disparity image /stereo/disparity. the topic is empty. afterwards i have check the node connection using rqt_graph. its is showing three node : left_driver, right_driver, and stereo/stereo_image_proc. the prefix stereo is for the addition of namespace. the three nodes are not interconnected. should the node stereo_image_proc subscribe from the left_driver and right_driver node. if yes how am i supposed to do the connection.

if i launch only the stereo_image_proc node without the driver nodes it is showing

[WARN] [1415813115.021826292]: The input topic '/stereo/left/image_raw' is not yet advertised
[ WARN] [1415813115.021923430]: The input topic '/stereo/left/camera_info' is not yet advertised
[ WARN] [1415813115.021964487]: The input topic '/stereo/right/image_raw' is not yet advertised
[ WARN] [1415813115.021984075]: The input topic '/stereo/right/camera_info' is not yet advertised

well with the driver node this error is not showing. so i guess the stereo_image_proc node is subscribing form the driver nodes. But the /stereo/disparity topic is empty and in the rqt_graph is also not showing the interconnection.

i do not know what i am missing and stuck in here.... thanks in advance..

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-11-12 14:15:29 -0600

ahendrix gravatar image

It may be that the camera drivers are not publishing images, or it may be that the image topics are not remapped properly.

I would start by verifying that both camera drivers are publishing images; you should be able to view the image from each camera with image_view or rqt_image_view. You should also check and make sure that messages are published on the camera_info topic for each camera.

I think the prosilica node defaults to a polled mode, so you may want to check that both cameras are set to streaming mode.

If you're starting the stereo_image_proc node from a launch file, roslaunch may be hiding the warning messages from you; you can try adding the --screen option to roslaunch or adding the output="screen" attribute to your <node> tag.

edit flag offensive delete link more

Comments

thank you very much.. i will give a try and let you know...

Robot gravatar imageRobot ( 2014-11-13 02:33:21 -0600 )edit

hey thanks again man... it worked.. But we have to add _approximate_sync:=True _ in both the nodes ROS_NAMESPACE=stereo rosrun stereo_image_proc stereo_image_proc _approximate_sync:=True _ rosrun image_view stereo_view stereo:=stereo image:=image_rect _approximate_sync:=True _queue_size:=10

Robot gravatar imageRobot ( 2014-11-13 03:53:37 -0600 )edit

If you have to use the appoximate sync flag, it probably means that your cameras are not triggering at the same time. I don't know the specifics, but it should be possible to run a trigger wire from one camera to the other and configure them so that they trigger at the same time.

ahendrix gravatar imageahendrix ( 2014-11-13 13:43:32 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-11-12 11:32:37 -0600

Seen: 432 times

Last updated: Nov 12 '14