Ask Your Question
0

Couldn't find executable below /home/leroy/catkin_ws/tum_ardrone

asked 2014-10-06 05:33:34 -0600

leroyv13 gravatar image

updated 2014-10-06 06:18:11 -0600

Hi,

i am fairly new to this, but whatever i try i cant seem to fix or see the problem here. i have a catkin workspace: catkin_ws

i`ve installed the tum_ardrone package accordingly:

  • cd catkin_ws
  • git clone git://github.com/tum-vision/tum_ardrone.git -b hydro-devel
  • export ROS_PACKAGE_PATH=$ROS_PACKAGE_PATH:catkin_ws/tum_ardrone tum_ardrone -b hydro-devel
  • cd tum_ardrone
  • rosmake tum_ardrone

added this to my .bashrc file: export ROS_PACKAGE_PATH=~/catkin_ws:${ROS_PACKAGE_PATH} and : source /home/leroy/catkin_ws/devel/setup.bash

when using rosmake it gives me a load of messages: "No Makefile in package catkin" this goes for every package

i noticed there wasnt a makefile. so i tried adding one manually with this line in it: include $(shell rospack find mk)/cmake.mk this still doesn`t change anything

when i am trying to run any of the 3 nodes in this package i get the following error: "Couldn't find executable below /home/leroy/catkin_ws/tum_ardrone"

ive also found a solution on this site where was stated that rosmake doesnt alway coop with catkin and therefore sometimes only make needs to be used. this gives me the following:

  • cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=/opt/ros/hydro/share/ros/core/rosbuild/rostoolchain.cmake ..
  • The C compiler identification is GNU
  • The CXX compiler identification is GNU
  • Check for working C compiler: /usr/bin/gcc
  • Check for working C compiler: /usr/bin/gcc -- works
  • Detecting C compiler ABI info
  • Detecting C compiler ABI info - done --Check for working CXX compiler: /usr/bin/c++
  • Check for working CXX compiler: /usr/bin/c++ -- works
  • Detecting CXX compiler ABI info
  • Detecting CXX compiler ABI info - done
  • Using CATKIN_DEVEL_PREFIX: /home/leroy/catkin_ws/tum_ardrone/build/devel
  • Using CMAKE_PREFIX_PATH: /opt/ros/hydro
  • This workspace overlays: /opt/ros/hydro
  • Found PythonInterp: /usr/bin/python (found version "2.7.3")
  • Using PYTHON_EXECUTABLE: /usr/bin/python
  • Python version: 2.7
  • Using Debian Python package layout
  • Using CATKIN_ENABLE_TESTING: ON
  • Call enable_testing()
  • Using CATKIN_TEST_RESULTS_DIR: /home/leroy/catkin_ws/tum_ardrone/build/test_results
  • Looking for include files CMAKE_HAVE_PTHREAD_H
  • Looking for include files CMAKE_HAVE_PTHREAD_H - found
  • Looking for pthread_create in pthreads
  • Looking for pthread_create in pthreads - not found
  • Looking for pthread_create in pthread
  • Looking for pthread_create in pthread - found
  • Found Threads: TRUE
  • Found gtest sources under '/usr/src/gtest': gtests will be built
  • catkin 0.5.89
  • CMake Error at /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:75 (find_package): Could not find a configuration file for package ardrone_autonomy.

    • Set ardrone_autonomy_DIR to the directory containing a CMake configuration file for ardrone_autonomy. The file will have one of the following names:

    • ardrone_autonomyConfig.cmake

    • ardrone_autonomy-config.cmake
  • Call Stack (most recent call first):

  • CMakeLists.txt:9 (find_package)

  • Using these message generators: gencpp;genlisp;genpy

  • tum_ardrone: 1 messages, 5 services
  • CMake Warning at /opt/ros/hydro/share/catkin/cmake/catkin_package.cmake:409 (message): catkin_package() include dir '/home/leroy/catkin_ws/tum_ardrone/build/devel/include' should be placed in the devel space instead of the build space
  • Call Stack (most recent call first): /opt/ros/hydro/share/catkin/cmake/catkin_package.cmake:98 (_catkin_package) CMakeLists.txt:64 (catkin_package ...

(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-10-07 16:35:57 -0600

Murilo F. M. gravatar image

updated 2014-10-07 16:37:05 -0600

There are two central concepts which you must firstly understand before attempting to do what you are doing.

Firstly, you are mixing up catkin and rosbuild workspaces/build systems. When using catkin workspaces, you should run the command catkin_make to build the packages within the given workspace.

Secondly, the source of all ROS packages compatible with catkin must be in catkin_ws/src/, and not in the root folder of your workspace.

See this link for further information.

I hope it helps!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-10-06 05:33:34 -0600

Seen: 524 times

Last updated: Oct 07 '14