Rviz "No transform from [] to []" without /joint_states

asked 2014-09-08 20:23:08 -0600

Eric Schneider gravatar image

Hi,

I'm trying to display a robot using rviz, and when I start up the visualizer it gives me a plethora of "no transform from [link_1] to [link_2]" errors under the RobotModel tab if I'm not publishing to the /joint_states topic as rviz starts.

I'm trying to run the visualizer, then run rosbag and view it. The problem is, unless I run rosbag right as I'm starting up the visualizer I get these errors. I've got a subscriber taking the rosbag messages and publishing /joint_states with the data.

The odd thing is, when I took that subscriber and published an initial one-off [0, 0, 0, 0, 0, 0] message (formatted as it would be for an actual message, with the same joint names and everything) I got the same errors.

Any ideas? Thanks!

edit retag flag offensive close merge delete

Comments

1

So what is your actual question? The robot model needs the /joint_states topic, where else from should it know how to display the robot?

BennyRe gravatar imageBennyRe ( 2014-09-09 00:00:31 -0600 )edit

You're right, but I tried publishing an initial /joint_states message (same format as the actual message, zero values for each joint) and that still caused errors. I thought publishing a correctly formatted message would initialize the visualizer and get it to wait for the stream of actual messages.

Eric Schneider gravatar imageEric Schneider ( 2014-09-09 07:15:18 -0600 )edit

Do you publish this message before or after startup of RViz?

BennyRe gravatar imageBennyRe ( 2014-09-09 23:22:19 -0600 )edit