Ask Your Question
1

move_base launch fails due to: cannot marshal None unless allow_none is enabled [closed]

asked 2014-09-03 02:55:24 -0500

Dear all,

I was following the navigation tutorial for ROS Hydro installed on my UDOO board robot.

I follow the tutorial on the Navigation ROS Wiki but, launching the move_base.launch file, I have a

cannot marshal None unless allow_none is enabled

error.

Those are my yaml files:

base_local_planner_params.yaml

TrajectoryPlannerROS:
  max_vel_x: 0.45
  min_vel_x: 0.1
  max_rotational_vel: 1.0
  min_in_place_rotational_vel: 0.4

  acc_lim_th: 3.2
  acc_lim_x: 2.5
  acc_lim_y: 2.5

  holonomic_robot: false

local_costmap_params.yaml

local_costmap:
  global_frame: odom
  robot_base_frame: base_link
  update_frequency: 5.0
  publish_frequency: 2.0
  static_map: false
  rolling_window: true
  width: 6.0
  height: 6.0
  resolution: 0.05

costmap_common_params.yaml

obstacle_range: 2.5
raytrace_range: 3.0
robot_radius: 0.30
inflation_radius: 0.55
observation_sources: laser_scan_sensor
laser_scan_sensor: {sensor_frame: base_laser, data_type: LaserScan, topic; laser_scan, marking: true, clearing: true}

global_costmap_params.yaml

global_costmap:
  global_frame: /map
  robot_base_frame: base_link
  update_frequency: 5.0
  static_map: false

amcl_diff.launch:

<launch>
  <node pkg="amcl" type="amcl" name="amcl" output="screen">
    <!-- Publish scans from best pose at a max of 10 Hz -->
    <param name="odom_model_type" value="diff"/>
    <param name="odom_alpha5" value="0.1"/>
    <param name="transform_tolerance" value="0.2" />
    <param name="gui_publish_rate" value="10.0"/>
    <param name="laser_max_beams" value="30"/>
    <param name="min_particles" value="500"/>
    <param name="max_particles" value="5000"/>
    <param name="kld_err" value="0.05"/>
    <param name="kld_z" value="0.99"/>
    <param name="odom_alpha1" value="0.2"/>
    <param name="odom_alpha2" value="0.2"/>
    <!-- translation std dev, m -->
    <param name="odom_alpha3" value="0.8"/>
    <param name="odom_alpha4" value="0.2"/>
    <param name="laser_z_hit" value="0.5"/>
    <param name="laser_z_short" value="0.05"/>
    <param name="laser_z_max" value="0.05"/>
    <param name="laser_z_rand" value="0.5"/>
    <param name="laser_sigma_hit" value="0.2"/>
    <param name="laser_lambda_short" value="0.1"/>
    <param name="laser_lambda_short" value="0.1"/>
    <param name="laser_model_type" value="likelihood_field"/>
    <!-- <param name="laser_model_type" value="beam"/> -->
    <param name="laser_likelihood_max_dist" value="2.0"/>
    <param name="update_min_d" value="0.2"/>
    <param name="update_min_a" value="0.5"/>
    <param name="odom_frame_id" value="odom"/>
    <param name="resample_interval" value="1"/>
    <param name="transform_tolerance" value="0.1"/>
    <param name="recovery_alpha_slow" value="0.0"/>
    <param name="recovery_alpha_fast" value="0.0"/>
  </node>
</launch>

and finally the move_base.launch

<launch>

  <include file="$(find geduino_navigation)/launch/amcl_diff.launch" />

  <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
    <rosparam file="$(find geduino_navigation)/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find geduino_navigation)/costmap_common_params.yaml" command="load" ns="local_costmap" />
    <rosparam file="$(find geduino_navigation)/local_costmap_params.yaml" command="load" />
    <rosparam file="$(find geduino_navigation)/global_costmap_params.yaml" command="load" />
    <rosparam file="$(find geduino_navigation)/base_local_planner_params.yaml" command="load" />
  </node>

</launch>

When I try to launch move_base.launch I get this error message:

[roslaunch][INFO] 2014-09-03 07:00:27,886: Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
[roslaunch][INFO] 2014-09-03 07:00:27,898: Done checking log file disk usage. Usage is <1GB.
[roslaunch][INFO] 2014-09-03 07:00:27,900: roslaunch starting with args ['/opt/ros/hydro/bin/roslaunch', 'geduino_navigation', 'move_base.launch']
[roslaunch][INFO] 2014-09-03 07:00:27,900: roslaunch env is {'ROS_DISTRO': 'hydro', 'LESSOPEN': '| /usr/bin/lesspipe %s', 'HUSHLOGIN': 'FALSE', 'CPATH': '/home/udoo ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by ahendrix
close date 2014-09-03 12:40:17.816743

Comments

Wrong reason. The right reason to close this question is RESOLVED.

afranceson gravatar imageafranceson ( 2014-09-03 04:29:41 -0500 )edit

You can also click the check box next to my answer to mark it as the correct answer.

ahendrix gravatar imageahendrix ( 2014-09-03 12:40:59 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-09-03 03:20:04 -0500

ahendrix gravatar image

I don't see anything obvious wrong with your parameter files.

This sort of error usually happens when there's a missing parameter somewhere. The best way to narrow it down is to start commenting out the <rosparam> lines in your move_base launch file until you find the line that's causing problems, and then take another look at that file to figure out why it fails to load.

edit flag offensive delete link more
1

answered 2014-09-03 04:27:42 -0500

Dear ahendrix,

following your suggestion I found the error: ';' used instead ':' in costmap_common_params.yaml

Thanks for your support. Alessandro

edit flag offensive delete link more

Comments

For me it was indentation mismatch in a yaml file.

hansolo gravatar imagehansolo ( 2019-02-28 08:02:45 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-09-03 02:55:24 -0500

Seen: 2,288 times

Last updated: Sep 03 '14