Ask Your Question
1

ARM raring nmea_navsat_driver rosdep [closed]

asked 2014-08-18 22:16:29 -0600

l0g1x gravatar image

I am using a parallella embedded system that uses a cortex A9 ARMHF architecture and am trying to get nmea_navsat_driver to work. I can download the source for from github and rosmake it without any problems. When i catkin_make my project, no errors show up. But when i try to run nmea_navsat_driver, nothing show up when tabbing for rosrun/roslaunch. So i tried to install the debian package for nmea_navsat_driver through sudo apt-get install, but i am getting a rosdep error saying: "ros-hydro-nmea-navsat-driver : Depends: python-serial but it is not installable". I tried to find and install python-serial from source, but had no luck in finding where the source is located. If i try to do "rosdep install python-serial" it tells me "ERROR: Rosdep cannot find all required resources to answer your query. Missing resource python-serial" and then lists my ROS path [0] = /opt/ros/hydro .... and so forth.

Does anybody know how i can get the nmea_navsat_driver to install on ARM? And if so, how do i overcome this dependency issue.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by l0g1x
close date 2015-04-02 21:50:06.569114

Comments

Can you post the exact error you get when you run sudo apt-get install python-serial ?

ahendrix gravatar imageahendrix ( 2014-08-18 23:56:04 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-08-19 00:00:24 -0600

ahendrix gravatar image

According to https://launchpad.net/ubuntu/raring/a... , the python-serial package should be available on Ubuntu Raring on armhf.

Raring is no longer supported by Ubuntu, so you should make sure that your apt sources are pointed to the ubuntu old-releases server.

edit flag offensive delete link more

Comments

I fixed the issue and thought that python-serial was ros package so i tried using rosdep to install it. sudo apt-get install python-serial is what i needed and it worked.

l0g1x gravatar imagel0g1x ( 2014-08-19 13:38:36 -0600 )edit

I am working with l0g1x, and I misunderstood that python-serial is not a ROS library. Sure enough you are correct it is supported, but I could not install it with the "sudo apt-get install" comand, I had to pull the debian package and install it with "dpkg". --John chicagoedt.org

Gamedrummer gravatar imageGamedrummer ( 2014-08-19 13:39:26 -0600 )edit
2

answered 2014-08-18 23:23:26 -0600

updated 2014-08-18 23:24:02 -0600

Try sudo pip install pyserial to install python-serial.

edit flag offensive delete link more

Comments

1

pyserial is what i needed. but im not using pip for my package manager but apt-get instead. Thanks though.

l0g1x gravatar imagel0g1x ( 2014-08-19 13:39:08 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2014-08-18 22:16:29 -0600

Seen: 177 times

Last updated: Aug 19 '14