Ask Your Question
1

Problem of installing kobuki in turtlebot installation (Indigo)

asked 2014-08-13 22:54:26 -0500

kevinma gravatar image

Hello,

I have a problem when I install kobuki in turtlebot installation of indigo. Following the tutorial, there was nothing wrong with rocon. However, when I continued to kobuki and run "rosdep install --from-paths src -i -y", I got the following error messages:

$ rosdep install --from-paths src -i -y
...
executing command [sudo apt-get install -y ros-indigo-kobuki-apps]
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ros-indigo-kobuki-apps
ERROR: the following rosdeps failed to install
  apt: command [sudo apt-get install -y ros-indigo-kobuki-apps] failed

The packages before "ros-indigo-kobuki-apps" (e.g., "ros-indigo-move-base-msgs") were installed without an error when running "rosdep install --from-paths src -i -y", but "ros-indigo-kobuki-apps" cannot be located.

Any help would be appreciated.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2014-08-13 23:21:39 -0500

ahendrix gravatar image

It looks like the kobuki_apps package was released quite recently and isn't available in the public repository yet: http://www.ros.org/debbuild/indigo.ht...

I would wait for the next synchronization announcement on the ros-users mailing list and then try again, or install kobuki_apps from source.

edit flag offensive delete link more
0

answered 2014-08-19 07:50:52 -0500

Nodetx gravatar image

I'm in the same boat. I went back and rebuilt on Hyrdo instead of Indigo. I got the exact same error as you did a couple days ago, and found Hydro has a deb I could just install with apt-get which worked like a charm.

edit flag offensive delete link more

Comments

The only problem I'm still having is my workstation is on 14.04 Trusty, which runs ROS Indigo, but my turtlebot install is running Hydro, which only supports 12.04 - 13.04 so I either have to wait for the Turtlebot Indigo to work or install an older Linux workstation.

Nodetx gravatar image Nodetx  ( 2014-08-19 08:03:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-08-13 22:54:26 -0500

Seen: 1,115 times

Last updated: Aug 13 '14