Ask Your Question
0

ROSJOY settings

asked 2014-08-12 09:19:36 -0500

dshimano gravatar image

updated 2014-08-12 09:23:03 -0500

Hi, I'm running on Ubuntu 12.04 and hydro,

When using a joystick with my computer I see it assigned as js1. With nothing plugged into my computer, when I run the command ls /dev/input/' there is a js0 listed, I don't know what it is. Anyway, when I use rosrun joy joy_node I get an error

[ERROR] [1407853001.741326266]: [registerPublisher] Failed to contact master at [localhost:11311].  Retrying...

unless I first do

rosparam set joy_node/dev "/dev/input/js1"

but I need to do this every time I use ROS. Is there a way to save the setting or something like that?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-08-12 10:25:09 -0500

You can make a launch file and set that as the port you want to use.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-12 09:19:36 -0500

Seen: 52 times

Last updated: Aug 12 '14

Related questions