Ask Your Question
0

catkin_make_isolated: which has been found in [path] but it is not a catkin package

asked 2014-08-08 21:22:51 -0600

I am building from source with an isolated catkin workspace. I wonder why it throws "not a catkin package", although catkin_make_isolated is supposed to build plain cmake projects, too.

-- Using PYTHON_EXECUTABLE: /usr/bin/python
-- Python version: 2.7
-- Using Debian Python package layout
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /ws/catkin/build_isolated/eigen_conversions/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- catkin 0.5.88
CMake Error at /ws/catkin/src/catkin/cmake/catkin_package.cmake:176 (message):
  catkin_package() CATKIN_DEPENDS on 'orocos_kdl', which has been found in
  '/ws/catkin/build_isolated/orocos_kdl/devel/orocos_kdl-config.cmake', but
  it is not a catkin package
Call Stack (most recent call first):


  /ws/catkin/src/catkin/cmake/catkin_package.cmake:98 (_catkin_package)
  CMakeLists.txt:10 (catkin_package)


-- Configuring incomplete, errors occurred!
See also "/ws/catkin/build_isolated/eigen_conversions/CMakeFiles/CMakeOutput.log".
See also "/ws/catkin/build_isolated/eigen_conversions/CMakeFiles/CMakeError.log".
make: *** [cmake_check_build_system] Error 1
<== Failed to process package 'eigen_conversions': 
  Command '/ws/catkin/devel_isolated/geometry_msgs/env.sh make cmake_check_build_system' returned non-zero exit status 2
edit retag flag offensive close merge delete

Comments

Which version of ROS are you using? Which version of eigen_conversions are you trying to build? I ask because it looks like orocos_kdl moved from a catkin package to a cmake package between Groovy and Hydro.

ahendrix gravatar imageahendrix ( 2014-08-11 23:17:00 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-08-09 23:19:55 -0600

tfoote gravatar image

updated 2014-08-09 23:20:08 -0600

catkin_make_isolated is fine to build packages which are not catkin packages.

Your problem is that you cannot use a CATKIN_DEPENDS on a non-catkin package. You have to use DEPENDS. catkin CMakeLists.txt documentation

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-08 21:22:51 -0600

Seen: 957 times

Last updated: Aug 09 '14