Ask Your Question
0

terminate called after throwing an instance of 'openni_wrapper::OpenNIException'

asked 2014-08-04 23:15:37 -0600

charkoteow gravatar image

updated 2014-08-07 04:09:39 -0600

Tried the 3D Visualisation tutorial for the turtlebot. I'm having a hard time launching the kinect on my turtlebot laptop. Below are the terminal logs. (note that user@eko-gateway is my turtlebot laptop)

user@eko-gateway:~$ roslaunch turtlebot_bringup 3dsensor.launch 
... logging to /home/user/.ros/log/8a2a9104-1c4a-11e4-9db6-48d2241d08a9/roslaunch-eko-gateway-9515.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://10.42.0.1:34058/

SUMMARY
========

PARAMETERS
 * /camera/camera_nodelet_manager/num_worker_threads
 * /camera/depth_rectify_depth/interpolation
 * /camera/depth_registered_rectify_depth/interpolation
 * /camera/disparity_depth/max_range
 * /camera/disparity_depth/min_range
 * /camera/disparity_registered_hw/max_range
 * /camera/disparity_registered_hw/min_range
 * /camera/disparity_registered_sw/max_range
 * /camera/disparity_registered_sw/min_range
 * /camera/driver/depth_camera_info_url
 * /camera/driver/depth_frame_id
 * /camera/driver/depth_registration
 * /camera/driver/device_id
 * /camera/driver/rgb_camera_info_url
 * /camera/driver/rgb_frame_id
 * /depthimage_to_laserscan/output_frame_id
 * /depthimage_to_laserscan/range_min
 * /depthimage_to_laserscan/scan_height
 * /rosdistro
 * /rosversion

NODES
  /camera/
    camera_nodelet_manager (nodelet/nodelet)
    debayer (nodelet/nodelet)
    depth_metric (nodelet/nodelet)
    depth_metric_rect (nodelet/nodelet)
    depth_points (nodelet/nodelet)
    depth_rectify_depth (nodelet/nodelet)
    depth_registered_rectify_depth (nodelet/nodelet)
    disparity_depth (nodelet/nodelet)
    disparity_registered_hw (nodelet/nodelet)
    disparity_registered_sw (nodelet/nodelet)
    driver (nodelet/nodelet)
    points_xyzrgb_hw_registered (nodelet/nodelet)
    points_xyzrgb_sw_registered (nodelet/nodelet)
    rectify_color (nodelet/nodelet)
    rectify_ir (nodelet/nodelet)
    rectify_mono (nodelet/nodelet)
    register_depth_rgb (nodelet/nodelet)
  /
    depthimage_to_laserscan (nodelet/nodelet)

ROS_MASTER_URI=http://10.42.0.1:11311

core service [/rosout] found
process[camera/camera_nodelet_manager-1]: started with pid [9533]
[ INFO] [1407210380.835627720]: Initializing nodelet with 4 worker threads.
process[camera/driver-2]: started with pid [9555]
process[camera/debayer-3]: started with pid [9576]
process[camera/rectify_mono-4]: started with pid [9591]
[ INFO] [1407210384.245259146]: Number devices connected: 1
[ INFO] [1407210384.247759899]: 1. device on bus 001:77 is a SensorV2 (2ae) from PrimeSense (45e) with serial id 'A00364A15558132A'
[ INFO] [1407210384.256431370]: Searching for device with index = 1
[ INFO] [1407210384.380931401]: Opened 'SensorV2' on bus 1:77 with serial number 'A00364A15558132A'
process[camera/rectify_color-5]: started with pid [9633]
process[camera/rectify_ir-6]: started with pid [9672]
process[camera/depth_rectify_depth-7]: started with pid [9695]
[ INFO] [1407210387.201221214]: rgb_frame_id = '/camera_rgb_optical_frame' 
[ INFO] [1407210387.201518310]: depth_frame_id = '/camera_depth_optical_frame' 
[ WARN] [1407210387.253713214]: Camera calibration file /home/user/.ros/camera_info/rgb_A00364A15558132A.yaml not found.
[ WARN] [1407210387.255078906]: Using default parameters for RGB camera calibration.
[ WARN] [1407210387.256739764]: Camera calibration file /home/user/.ros/camera_info/depth_A00364A15558132A.yaml not found.
[ WARN] [1407210387.259620976]: Using default parameters for IR camera calibration.
process[camera/depth_metric_rect-8]: started with pid [9767]
process[camera/depth_metric-9]: started with pid [9862]
process[camera/depth_points-10]: started with pid [9950]
process[camera/register_depth_rgb-11]: started with pid [10021]
process[camera/points_xyzrgb_sw_registered-12]: started with pid [10090]
process[camera/depth_registered_rectify_depth-13]: started with pid [10174]
process[camera/points_xyzrgb_hw_registered-14]: started with pid [10249]
process[camera/disparity_depth-15]: started with pid [10310]
process[camera/disparity_registered_sw-16]: started with pid [10358]
process[camera/disparity_registered_hw-17]: started with pid [10391]
process[depthimage_to_laserscan-18]: started with pid [10438]
terminate called after throwing an instance of 'openni_wrapper::OpenNIException'
  what():  virtual void openni_wrapper::OpenNIDevice::startImageStream() @ /tmp/buildd/ros-hydro-openni-camera-1.9.2-0precise-20140720-0559/src/openni_device.cpp @ 224 : starting image stream failed. Reason: Failed to send a USB control request!
[camera/camera_nodelet_manager-1] process has died [pid 9533, exit code -6, cmd /opt/ros/hydro/lib/nodelet/nodelet manager __name:=camera_nodelet_manager ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2014-08-05 16:09:04 -0600

ahubers gravatar image

It says at the top that you launched this from user@eko-gateway. However,

roslaunch turtlebot_bringup 3dsensor.launch

must be run on the Turtlebot. I know that the turtlebots by default have username "turtlebot", so I'm just curious if this was ran on the turtlebot or your workstation?

edit flag offensive delete link more

Comments

Ahh I'm sorry, I've edited my post to mention that the user@eko-gateway is my turtlebot laptop. Anyways, I've just updated my depthimage_to_laserscan package. I'll post my progress after I try running this tutorial again later. Thank you for your input btw!

charkoteow gravatar imagecharkoteow ( 2014-08-05 22:12:41 -0600 )edit

yes after updating the package, the process no longer being terminated after process[depthimage_to_laserscan-18]. I believe, this is now solved.

charkoteow gravatar imagecharkoteow ( 2014-08-06 03:11:35 -0600 )edit

Sounds great. Let me know if this gives you any issues with depth registration; my depth_registered stream is all 0's at the moment.

ahubers gravatar imageahubers ( 2014-08-06 12:05:35 -0600 )edit

How do you check that?

charkoteow gravatar imagecharkoteow ( 2014-08-07 04:06:40 -0600 )edit

turtlebot_bringup 3dsensor.launch seems to run depth_registration by default. Running rostopic echo camera/depth_registered/image_raw should show you the values of the depth_registered image, and whether or not it works.

ahubers gravatar imageahubers ( 2014-08-07 11:23:29 -0600 )edit

sorry for the late reply, indeed my rostopic echo camera/depth_registered/image_raw also came out as nothing.

charkoteow gravatar imagecharkoteow ( 2014-08-13 03:19:59 -0600 )edit
0

answered 2014-08-07 04:07:37 -0600

charkoteow gravatar image

Updated the depthimage_to_laserscan package, the process no longer being terminated after process[depthimage_to_laserscan-18] now.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-04 23:15:37 -0600

Seen: 735 times

Last updated: Aug 07 '14