Ask Your Question
1

Problems creating own robot in Gazebo with catkin_ws

asked 2014-07-29 07:35:57 -0600

schultza gravatar image

updated 2014-07-30 08:20:43 -0600

Hey,

I am still learning ROS and Gazebo. Right now I am using ROS-INDIGO and Gazebo 2.2. so I went through some tutorials at gazebosim.org especially at this one Using roslaunch and tried to follow all the steps. Unfortunately I was not able to complete this one (and I see for the next tutorials an URDF model in a catkin workspace is required). So the problem is that so far I dint create my own robot in URDF yet and the Baxter robot which is suggested, if you didn't create your own robot so far, doesn't work (seems to be a more common problem as i read in another post). So my question is now, can someone suggest a tutorials in which I can create my first (maybe simple) robot so i can keep on doing the following tutorials and complete this tutorial?

Thanks


Edit#1

First Terminal and roslaunch the world see here:

schultza@Andreas:~/catkin_ws2$ roslaunch test_gazebo_ros test.launch
... logging to /home/schultza/.ros/log/affe9244-17eb-11e4-9c7b-485ab604aada/roslaunch-Andreas-3956.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://Andreas:55317/

SUMMARY
========

PARAMETERS
 * /rosdistro: indigo
 * /rosversion: 1.11.7
 * /use_sim_time: True

NODES
  /
    gazebo (gazebo_ros/gzserver)
    gazebo_gui (gazebo_ros/gzclient)

auto-starting new master
process[master]: started with pid [3968]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to affe9244-17eb-11e4-9c7b-485ab604aada
process[rosout-1]: started with pid [3981]
started core service [/rosout]
process[gazebo-2]: started with pid [4005]
process[gazebo_gui-3]: started with pid [4011]
Gazebo multi-robot simulator, version 2.2.2
Copyright (C) 2012-2014 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Gazebo multi-robot simulator, version 2.2.2
Copyright (C) 2012-2014 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Msg Waiting for master.[ INFO] [1406726180.078664109]: Finished loading Gazebo ROS API Plugin.
Msg Waiting for master[ INFO] [1406726180.080004456]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...

Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 141.7.155.96

Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 141.7.155.96
[ INFO] [1406726181.483034230, 0.024000000]: waitForService: Service [/gazebo/set_physics_properties] is now available.
[ INFO] [1406726181.559263363, 0.097000000]: Physics dynamic reconfigure ready.
Error [Param.cc:181] Unable to set value [1,0471975511965976] for key[horizontal_fov]
Error [Param.cc:181] Unable to set value [0,100000001] for key[near]

After in a new terminal, rosrun ing the baxter, see here and also see the error which occures:

schultza@Andreas:~/catkin_ws2/src$ rosrun gazebo_ros spawn_model -file `rospack find baxter_description`/urdf/baxter.urdf -urdf -z 1 -model baxter
Traceback (most recent call last):
  File "/home/schultza/catkin_ws/src/gazebo_ros_pkgs/gazebo_ros/scripts/spawn_model", line 25, in <module>
    from gazebo_ros import gazebo_interface
  File "/home/schultza/catkin_ws/src/gazebo_ros_pkgs/gazebo_ros/src/gazebo_ros/gazebo_interface.py", line 8, in <module>
    from gazebo_msgs.msg import *
ImportError: No module named msg ...
(more)
edit retag flag offensive close merge delete

Comments

Nothing new because of the error "No module named msg" ? I faced this error already sometimes more

schultza gravatar imageschultza ( 2014-08-04 08:40:10 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-07-29 08:01:28 -0600

mateus03 gravatar image

Hi!

You should download a urdf model, since it will be simpler to just spawn it in gazebo. If you want to create your own model you can follow the tutorial gazebo build model. It explains how to build a simple mobile robot.

edit flag offensive delete link more

Comments

Where is the difference to spawn it directly in Gazebo or via catkin workspace?

schultza gravatar imageschultza ( 2014-07-29 08:32:33 -0600 )edit

If you just spawn the model in Gazebo you'll have the model in the simulator but you'll not be able to control it with ros. If you want to use the model in ros you should use roslaunch to spawn it, so the topics from odometry and the sensors are published.

mateus03 gravatar imagemateus03 ( 2014-07-29 09:37:29 -0600 )edit

I want to control it with Ros and i tried to download the baxter robot, but while spawning with roslaunch gazebo crashes instantly

schultza gravatar imageschultza ( 2014-07-30 07:15:17 -0600 )edit

Can you edit your question to show the error that you get?

mateus03 gravatar imagemateus03 ( 2014-07-30 07:38:31 -0600 )edit

Yep did it

schultza gravatar imageschultza ( 2014-07-30 08:21:06 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-29 07:35:57 -0600

Seen: 657 times

Last updated: Jul 30 '14