Ask Your Question
0

Turtlebot simulation crashes when launched

asked 2014-07-24 13:19:00 -0600

Sammac gravatar image

updated 2014-07-26 01:14:11 -0600

I have installed the software like it is said in the page.

my system info is:

  • ubuntu 12.04
  • ros hydro
  • gazebo 1.9

However when i try to run it:

roslaunch turtlebot_gazebo turtlebot_empty_world.launch

gazebo crashes when he should spawn the bot. The log message i get when this happens is:

Dbg Plugin model name: mobile_base [spawn_turtlebot_model-4] process has finished cleanly log file: /home/samper/.ros/log/e4873b52-135d-11e4-bbd0-109add68f52e/spawn_turtlebot_model-4.log Segmentation fault (core dumped) [gazebo_gui-3] process has died [pid 25180, exit code 139, cmd /opt/ros/hydro/lib/gazebo_ros/gzclient __name:=gazebo_gui __log:=/home/samper/.ros/log/e4873b52-135d-11e4-bbd0-109add68f52e/gazebo_gui-3.log]. log file: /home/samper/.ros/log/e4873b52-135d-11e4-bbd0-109add68f52e/gazebo_gui-3.log

I don't know why it is happening, other urdf models like shadow hand and arm are working pretty nice.

------------- EDIT -------------

when i check the log files i get this information:

[rospy.client][INFO] 2014-07-24 20:11:12,989: init_node, name[/spawn_turtlebot_model], pid[25187]

[xmlrpc][INFO] 2014-07-24 20:11:12,989: XML-RPC server binding to 0.0.0.0:0

[xmlrpc][INFO] 2014-07-24 20:11:12,990: Started XML-RPC server [http ://samper-MacBookPro:46217/]

[rospy.init][INFO] 2014-07-24 20:11:12,990: ROS Slave URI: [http ://samper-MacBookPro:46217/]

[rospy.impl.masterslave][INFO] 2014-07-24 20:11:12,990: _ready: http ://samper-MacBookPro:46217/

[rospy.registration][INFO] 2014-07-24 20:11:12,991: Registering with master node http ://localhost:11311

[xmlrpc][INFO] 2014-07-24 20:11:12,991: xml rpc node: starting XML-RPC server

[rospy.init][INFO] 2014-07-24 20:11:13,090: registered with master

[rospy.rosout][INFO] 2014-07-24 20:11:13,090: initializing /rosout core topic

[rospy.rosout][INFO] 2014-07-24 20:11:13,093: connected to core topic /rosout

[rospy.simtime][INFO] 2014-07-24 20:11:13,094: initializing /clock core topic

[rospy.simtime][INFO] 2014-07-24 20:11:13,096: connected to core topic /clock

[rosout][INFO] 2014-07-24 20:11:13,098: Loading model xml from ros parameter

[rosout][INFO] 2014-07-24 20:11:13,103: Waiting for service /gazebo/spawn_urdf_model

[rospy.internal][INFO] 2014-07-24 20:11:13,321: topic[/clock] adding connection to [http: //samper-MacBookPro:44259/], count 0

[rospy.internal][INFO] 2014-07-24 20:11:13,363: topic[/rosout] adding connection to [/rosout], count 0

[rosout][INFO] 2014-07-24 20:11:13,406: Calling service /gazebo/spawn_urdf_model

[rosout][INFO] 2014-07-24 20:11:14,467: Spawn status: SpawnModel: Successfully spawned model

[rospy.core][INFO] 2014-07-24 20:11:14,470: signal_shutdown [atexit]

[rospy.internal][INFO] 2014-07-24 20:11:14,477: topic[/rosout] removing connection to /rosout

[rospy.internal][INFO] 2014-07-24 20:11:14,477: topic[/clock] removing connection to http: //samper-MacBookPro:44259/

[rospy.impl.masterslave][INFO] 2014-07-24 20:11:14,477: atexit

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-07-25 10:10:03 -0600

DevonW gravatar image

Check the log files and show us the output.

sudo cat /home/samper/.ros/log/e4873b52-135d-11e4-bbd0-109add68f52e/spawn_turtlebot_model-4.log

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-07-24 13:19:00 -0600

Seen: 521 times

Last updated: Jul 26 '14