Ask Your Question
1

Occassionally getting a Error32 Broken Pipe error when calling service from rospy

asked 2014-07-21 08:43:06 -0600

We´re using a SMACH based state machine that uses service calls to retrieve data from other nodes occasionally. Sometimes (We did not find a pattern when so far) the service call fails with "Error 32 Broken Pipe" (reported as the error string when catching exceptions of the service call). The call is made within one machine (so network connectivity issues should not be a problem). The service call also does not do any "weird" things like transmitting hundreds of megabytes of data or so. Due to time constraints and code complexity (RoboCup ;) ) I cannot post code examples currently, but any ideas about the possible cause could be are appreciated. I´m especially interested in understanding if this can happen due things we do in the service server or client or if this is more of a infrastructure/TCP communication problem (and external to ROS nodes).

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2014-07-21 15:24:38 -0600

ccapriotti gravatar image

Hmmm. Tough one.

Troubleshooting from the system point of view, a "broken pipe" is very typical of network, but could be that one of the programs died, either the "talker" or the "listener".

Any PID changes suggesting if any of them died ?

Instead of using the name of the computer (supposing you are), have you tried:

use 127.0.0.1

cheat your hosts file to always point the machine to its IP

have only one IP

check system logs for errors.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-21 08:43:06 -0600

Seen: 532 times

Last updated: Jul 21 '14