Ask Your Question
1

Problem running follower demo turtlebot

asked 2014-07-11 10:06:25 -0600

gerhenz gravatar image

updated 2014-07-14 03:39:40 -0600

I've just received a turtlebot and I'm having some trouble when I try to run the follower demo in the netbook that came along with the robot. The robot doesn't move when I run the command: $ roslaunch turtlebot_follower follower.launch

The output is:

[ INFO] [1405090576.551327448]: Number devices connected: 1
[ INFO] [1405090576.551600322]: 1. device on bus 003:24 is a SensorV2 (2ae) from PrimeSense (45e) with serial id '0000000000000000'
[ INFO] [1405090576.553242502]: Searching for device with index = 1
[ INFO] [1405090576.603033557]: Opened 'SensorV2' on bus 3:24 with serial number '0000000000000000'
[ INFO] [1405090577.265245722]: rgb_frame_id = '/camera_rgb_optical_frame' 
[ INFO] [1405090577.265818846]: depth_frame_id = '/camera_depth_optical_frame' 
[ WARN] [1405090577.280437487]: Camera calibration file /home/turtlebot/.ros/camera_info/rgb_0000000000000000.yaml not found.
[ WARN] [1405090577.280986866]: Using default parameters for RGB camera calibration.
[ WARN] [1405090577.281605477]: Camera calibration file /home/turtlebot/.ros/camera_info/depth_0000000000000000.yaml not found.
[ WARN] [1405090577.281993724]: Using default parameters for IR camera calibration.

I think it should have shown 2 devices connected (kinect and kobuki base). I tried disconnecting each one of them and running the code again and I discovered that the problem is that it is only considering the kinect as a connected device. Do I need to do anything else than connecting the provided usb cable between the base and the netbook? Using the command $lsusb it looks like the usb port is working properly.

Thanks in advance


EDIT: Thanks for the answer Devon, I've tried what you suggested but unfortunately it didn't work. I didn't find the topic cmd_vel, so I used the other command you suggest and the output was:

$ rostopic list | grep cmd_vel
/cmd_vel_mux/active, 
/cmd_vel_mux/input/navi, 
/cmd_vel_mux/input/safety_controller
/cmd_vel_mux/input/teleop
/cmd_vel_mux/parameter_descriptions
/cmd_vel_mux/parameter_updates
/follower_velocity_smoother/raw_cmd_vel

I assumed the topic I would like to verify is the last one. So I ran the follower application again while monitoring the topic, and I could check that it's not sending any velocity commands (assuming the topic I chose is the right one). The output was a bunch of:

linear: 
  x: 0.0
  y: 0.0
  z: 0.0
angular: 
  x: 0.0
  y: 0.0
  z: 0.0
---

Cheers, gerhenz

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-07-13 03:57:15 -0600

DevonW gravatar image

Has the turtlebot core been started? The follower is the application that runs on the turtlebot. The turtlebot core may need to be started:

roslaunch turtlebot_bringup minimal.launch

and you can verify that it is sending velocity commands by

rostopic echo cmd_vel

if you don't see cmd_vel, try:

rostopic list | grep cmd_vel

and retry the rostopic echo with the output from the above command.

Cheers, Devon

edit flag offensive delete link more

Comments

Devon, I've edited the question regarding the results of your suggestions. Cheers

gerhenz gravatar imagegerhenz ( 2014-07-14 03:36:47 -0600 )edit

Thanks. Did you try standing in-front of the robot when the follower.launch is played? There is a dead-zone, so make sure that is out of the way as well. If that's not the case: please after plugging in the usb to the turtlebot show me the output of cat /var/log/syslog

DevonW gravatar imageDevonW ( 2014-07-14 04:53:32 -0600 )edit

I was trying to stand too close to the kinect (probably inside the dead-zone). Everything works now. Thanks Devon!

gerhenz gravatar imagegerhenz ( 2014-07-14 06:52:47 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-11 10:06:25 -0600

Seen: 753 times

Last updated: Jul 14 '14