Ask Your Question
0

rgbdslam hydro no display

asked 2014-07-04 13:16:23 -0500

updated 2014-07-06 00:53:31 -0500

allenh1 gravatar image

Hi,

Has anyone encountered the problem in which rgbdslam does not display as showed in the picture? I am running hydro. Thanks a lot!

image description

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-07-05 18:34:12 -0500

The problem has been solved by typing $roscore first before typing

$roslaunch openni_launch openni.launch $rosrun rgbdslam rgbdslam

edit flag offensive delete link more

Comments

I still only get an empy window as shown in the picture at the top of this thread... pressing enter to start doesn't change things.

In the terminal that runs $roslaunch openni_launch openni.launch

I see a lot of messages TF2 exception Invalid argument "/camera_rgb_optical_frame" passed ...

monkeyiq gravatar image monkeyiq  ( 2014-09-18 07:05:01 -0500 )edit

Full single message block:

Invalid argument "/camera_rgb_optical_frame" passed to lookupTransform argument target_frame in tf2 frame_ids cannot start with a '/' like:

monkeyiq gravatar image monkeyiq  ( 2014-09-18 07:05:30 -0500 )edit

This is on 14.04.1 LTS using ROS Indigo.

monkeyiq gravatar image monkeyiq  ( 2014-09-18 07:06:24 -0500 )edit

I fixed that by updating the openni launch file and adding a prefix. Then I got images in the rgbdslam GUI!

monkeyiq gravatar image monkeyiq  ( 2014-09-18 07:41:26 -0500 )edit

I also have the same messages. @monkeyiq, can you give me more details on how to fix this one by adding a prefix?

yoo00 gravatar image yoo00  ( 2014-10-06 01:12:54 -0500 )edit

yooncs8, you need to remove "$(arg tf_prefix)/" from the rgb_frame_id and depth_frame_id parameters in openni.launch.

celston gravatar image celston  ( 2014-10-06 11:50:33 -0500 )edit

hi i had the same problem rgbdslam does not displayimage, i worked with hudro version, ubunto 12.04 and i still have the problem until now, please is there anyone who can help me?

sophye_turtlebot gravatar image sophye_turtlebot  ( 2015-03-27 06:56:27 -0500 )edit

@celston I already have updated file but it still giving the same error, e.g., <arg name="camera" default="camera"/> <arg name="rgb_frame_id" default="$(arg camera)_rgb_optical_frame"/> <arg name="depth_frame_id" default="$(arg camera)_depth_optical_frame"/> Any idea?

Zari gravatar image Zari  ( 2015-09-05 10:34:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-04 13:16:23 -0500

Seen: 350 times

Last updated: Jul 06 '14