Ask Your Question
2

Remocon Hydro Android app/Turtlebot Pairing error

asked 2014-06-26 21:44:46 -0600

syaz nyp fyp gravatar image

updated 2014-06-26 21:45:53 -0600

hi all.

I''m encountering a problem now when pairing my android device with the turtlebot. Using the Robot Remocon App (hydro), i managed to detect the turtlebot under "Scan the local network". After loading, it instantly display this error:

org.ros.exception.RosRuntimeException: timed out waiting for a gateway_info publication

<--screenshot image here--> = http: //tinypic.com/view.php?pic=5wuv7&s=8

However, i did set my ROS_IP/ROS_HOSTNAME/ROS_MASTER_URI on the turtlebot for multi-device-pc communication as the ros wiki tutorial states = (http: //wiki.ros.org/turtlebot/Tutorials/hydro/Network%20Configuration).

any help will be greatly appreciated. thanks in advance guys.

tried following the answer to a similar question "here" =

http: //answers.ros.org/question/110196/android-rocon_app_manager-pairing-error/

but to no avail. (so i decided to bring this up again)

insufficient karma to post links. sigh

edit retag flag offensive close merge delete

Comments

1

I asked a similar question there...are you by chance using an android that exposes two network interfaces?

Daniel Stonier gravatar imageDaniel Stonier ( 2014-06-30 01:27:29 -0600 )edit

ive checked and i doubt it's exposing to 2 network interfaces. Either ROS_IP or ROS_HOSTNAME needs to be set in bashrc right? just one will do? and it's supposed to be ROS_HOSTNAME=IP_OF_TURTLEBOT? am i right? I've done it. I'm really confused on what seems to be the problem now. thks a lot daniel

syaz nyp fyp gravatar imagesyaz nyp fyp ( 2014-07-01 03:23:37 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-07-01 21:15:22 -0600

syaz nyp fyp gravatar image

Finally got it working. Thanks to everyone. For the machine that is running roscore, you need not need to worry about ROS_MASTER_URI or ROS_HOSTNAME but you need to select the IP of your machine on the internal network. Exporting ROS_IP in ~/.bashrc

export ROS_IP=172.20.10.8

Need to make sure that ROS_IP is also set in the etc/hosts file by adding:

172.20.10.8 ROS_IP

edit flag offensive delete link more

Comments

I really have set the ROS_IP like above,but I failed.Can you tell me how to set it

Jie Sky gravatar imageJie Sky ( 2014-10-19 06:08:37 -0600 )edit
-1

answered 2014-10-27 21:04:35 -0600

Jie Sky gravatar image

Hello beautifull girl: When the remocon is once connected,remocon displays a list of the app pairs (robot and android) that you can start/stop remotely.For these app pars,do they need to be downloaded? any help will be greatly appreciated. thanks in advance.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-06-26 21:44:46 -0600

Seen: 830 times

Last updated: Oct 27 '14