Ask Your Question

can't locate node [turtle_teleop_joy] in package [learning_joy]

asked 2014-06-08 10:23:03 -0600

richkappler gravatar image

Using Hydro on Precise. Following the tutorials on joystick operation here and here. The joystick works, roscore is running, joy_node is running, when I do rostopic echo joy I see the vectors change as I expect when the joystick controls are moved. When I run roslaunch learning_joy turtle_joy.launch however, the joystick still works, topic echo shows still sending, but no movement of the turtle.

I'm still on the steep part of the learning curve so I could be wrong, but might this be a path problem? I've changed the launch file as suggested here (joy to joy_node) and also changed the last line from turtle_teleop to learning_joy (missed that bit on the tutorial) but still not getting it right. here's my screenshot:

roslaunch learning_joy turtle_joy.launch ... logging to /home/richard/.ros/log/68d0ca94-ef06-11e3-912a-00215c98e435/roslaunch-inga-7554.log
Checking log directory for disk usage. This may take awhile. 
Press Ctrl-C to interrupt 
Done checking log file disk usage. Usage is <1GB.

    started roslaunch server http://inga:32850/

    PARAMETERS * /axis_angular * /axis_linear * /rosdistro * /rosversion * /scale_angular * /scale_linear * /turtle_joy/deadzone * /turtle_joy/dev

    NODES / sim (turtlesim/turtlesim_node) teleop (learning_joy/turtle_teleop_joy) turtle_joy (joy/joy_node)


    core service [/rosout] found process[sim-1]: started with pid [7572] process[turtle_joy-2]: started with pid [7596] ERROR: cannot launch node of type [learning_joy/turtle_teleop_joy]: can't locate node [turtle_teleop_joy] in package [learning_joy]
edit retag flag offensive close merge delete



I have the same problem. Have you found the solution to your problem? Help, please!

Alex Ortega gravatar image Alex Ortega  ( 2015-07-18 15:24:12 -0600 )edit

Please do not use Answer form to ask questions, use comments or create your own question instead. ROS Answers is not a forum, but Q&A site.

Boris gravatar image Boris  ( 2015-07-19 07:55:09 -0600 )edit

I have followed the very same example from the book "Learning ROS for Robotics Programming second edition on Jade on ubuntu 15.04. I am also having the similar problem. Someone please sort it out. Thanks.

Abdul Mannan gravatar image Abdul Mannan  ( 2016-01-12 21:03:57 -0600 )edit

I also had the same issue .I solved it . After adding the the following lines(given below) in CMakeLists.txt . In the terminal I wrote : $ cd catkin_ws $ catkin_make

"add_executable(turtle_teleop_joy src/turtle_teleop_joy.cpp)

target_link_libraries(turtle_teleop_joy ${catkin_LIBRARIES})"

Suneet gravatar image Suneet  ( 2017-09-03 11:45:28 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2015-07-18 16:57:06 -0600

The line from original tutorial launch-file (on the second link you gave)

<node pkg="turtle_teleop" type="turtle_teleop_joy" name="teleop"/>

tells roslaunch to start a node by running turtle_teleop_joy executable (type parameter) which is located within turtle_teleop package (pkg parameter). If you change pkg parameter on this line roslaunch will search for the executable within another package/folder, i.e. learning_joy. So, if there is no such executable (node) there, then roslaunch will issue an error.

edit flag offensive delete link more

answered 2016-02-23 10:32:56 -0600

Had same problem on indigo solved by changing CMakeLists.txt to

cmake_minimum_required(VERSION 2.4.6) include($ENV{ROS_ROOT}/core/rosbuild/rosbuild.cmake) rosbuild_init() set(EXECUTABLE_OUTPUT_PATH ${PROJECT_SOURCE_DIR}/bin) set(LIBRARY_OUTPUT_PATH ${PROJECT_SOURCE_DIR}/lib)

find_package( catkin REQUIRED COMPONENTS joy roscpp turtlesim )

add_executable(turtle_teleop_joy src/turtle_teleop_joy.cpp) target_link_libraries(turtle_teleop_joy ${catkin_LIBRARIES})

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2014-06-08 10:23:03 -0600

Seen: 2,218 times

Last updated: Feb 23 '16