Ask Your Question
0

Creating ROS Workspace - catkin_make catkin_pkg error

asked 2014-05-31 01:18:31 -0500

kyo_udon gravatar image

updated 2014-05-31 09:09:55 -0500

William gravatar image

ROS VERSION : INDIGO (desktop-full) OS : Ubuntu 14.04

I install ROS using prebuild debian(sudo apt-get install ros-indigo-desktop-full). Going through ROS tutorials, i get the following error while creating a workspace(catkin_make)

ImportError: "from catkin_pkg.package import parse_package" failed: No module named catkin_pkg.package
Make sure that you have installed "catkin_pkg", it is up to date and on the PYTHONPATH.
CMake Error at /opt/ros/indigo/share/catkin/cmake/safe_execute_process.cmake:11 (message):
  execute_process(/home/kyo/anaconda/bin/python
  "/opt/ros/indigo/share/catkin/cmake/parse_package_xml.py"
  "/opt/ros/indigo/share/catkin/cmake/../package.xml"
  "/home/kyo/catkin_ws/build/catkin/catkin_generated/version/package.cmake")
  returned error code 1
Call Stack (most recent call first):
  /opt/ros/indigo/share/catkin/cmake/catkin_package_xml.cmake:63 (safe_execute_process)
  /opt/ros/indigo/share/catkin/cmake/all.cmake:141 (_catkin_package_xml)
  /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake:20 (include)
  CMakeLists.txt:52 (find_package)

-- Configuring incomplete, errors occurred!

extra info : i had anaconda installed in my ubuntu and running echo $PYHTONPATH return nothing.

edit retag flag offensive close merge delete

Comments

1

`anaconda` may be interfering, can you do `python -c "import catkin_pkg; print(catkin_pkg.__version__)"`?

William gravatar image William  ( 2014-05-31 09:10:55 -0500 )edit

This is what i got: Traceback (most recent call last): File "<string>", line 1, in <module> ImportError: No module named catkin_pkg

kyo_udon gravatar image kyo_udon  ( 2014-05-31 09:33:07 -0500 )edit

i am having the same issue, got any solution?

Kailegh gravatar image Kailegh  ( 2017-03-13 12:03:46 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted
0

answered 2015-01-16 14:35:45 -0500

candidcypher gravatar image

I believe that the issue is with a path conflict with ROS and Anaconda. I experienced the same thing a while back.

edit flag offensive delete link more
1

answered 2016-02-20 10:51:09 -0500

schwarmcyc gravatar image

$pip install catkin_pkg solve the problem Ubuntu 14.04 I got same erro when building ORK

edit flag offensive delete link more

Comments

I have met the same problem and tried your method, then it works! Can you give me an detailed explanation what this command works?

tengfei gravatar image tengfei  ( 2017-10-25 05:42:28 -0500 )edit
0

answered 2014-05-31 02:01:22 -0500

hsoltani gravatar image

sudo apt-get install ros doesn't work on Ubuntu 14.04. You should compile ROS or install Ubuntu 12.04.

edit flag offensive delete link more

Comments

Also catkin work on hydro version. I wonder if it can work on Indigo.

hsoltani gravatar image hsoltani  ( 2014-05-31 02:04:31 -0500 )edit

Yes, ROS Indigo packages are available for Ubuntu Trusty (14.04).

joq gravatar image joq  ( 2014-05-31 04:15:48 -0500 )edit
0

answered 2014-05-31 04:17:26 -0500

joq gravatar image

Looks like you need to install catkin_pkg:

sudo apt-get install python-catkin-pkg
edit flag offensive delete link more

Comments

python-catkin-pkg is already install along with ros-indigo-full-desktop. Tried it and all it did was change python-catkin-pkg to manually installed.

kyo_udon gravatar image kyo_udon  ( 2014-05-31 09:30:02 -0500 )edit
0

answered 2014-05-31 02:55:37 -0500

kyo_udon gravatar image

updated 2014-05-31 02:57:19 -0500

what do you mean not working? i just follow this link for the installation : http_wiki.ros.org/indigo/Installation/Ubuntu

i did not get any error during the installation. Only when i follow the tutorial up to "creating workspace" do i receive the error.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-31 01:18:31 -0500

Seen: 3,542 times

Last updated: May 31 '14