ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
1

indigo actionlib client cannot connect to the server [closed]

asked 2014-05-22 20:23:21 -0600

ST-Lab gravatar image

I tried to make actionlib client/server program on ROS Indigo/Ubuntu 14.04, but however, I've got a trouble that my actionlib client cannot connect to its server because the "ActionClient::waitForActionServerToStart()" will be always failed.

And also, this problem occurred in the "actionlib_tutorial" in ROS Indigo (ros-indigo-actionlib-tutorials).

By tracing the debug messages of ROS console, I found that the actionlib server tries to make connection but the client gets no response from status/feedback/result topics.

  1. In the "/opt/ros/indigo/include/actionlib/action_client.h", the function "ActionClient::statusCb()" was registered but never called at all.
  2. so that, in the "actionlib/src/connection_monitor.cpp", the function "ConnectionMonitor::processStatus()" could not notify its condition.
  3. then, in the "ConnectionMonitor::waitForActionServerToStart()", the variable "check_connection_condition_" has never success of its "timed_wait()".
  4. in the result, ActionClient::waitForActionServerToStar() will be failed.

In ROS Groovy, my program and "actionlib_tutorial" have worked fine.

What should I do?

Thank you.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by ST-Lab
close date 2014-05-24 21:30:09

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-05-24 17:24:50 -0600

fergs gravatar image

How is actionlib installed? If you are using debs and not on ros-shadow, or your source is old, this is a bug in version 1.11.1 ( https://github.com/ros/actionlib/issu... ) that prevented the conneciton monitor to work correctly. This is fixed in 1.11.2

edit flag offensive delete link more

Comments

Hello fergs. Thank you for your answer. I installed actionlib and other ROS packages by apt-get from public ROS repositry "http://packages.ros.org/ros/ubuntu trusty main". Along your advice, when I checked the version of the actionlib, it shows that. - ros-indigo-actionlib 1.11.1-0trusty-20140509-0158-+0000 - ros-indigo-actionlib-msgs 1.11.3-0trusty-20140508-2322-+0000 So far, today, the latest version which I can get from publich repositry is "1.11.1". I'll wait for the new fixed version.

ST-Lab gravatar image ST-Lab  ( 2014-05-24 20:03:37 -0600 )edit
1

Just a note, rather than closing a question, just click the checkmark next to the answer. This will mark the question as answered.

fergs gravatar image fergs  ( 2014-05-24 23:57:13 -0600 )edit

Thank you, fergs.

ST-Lab gravatar image ST-Lab  ( 2014-05-26 01:59:50 -0600 )edit
1

Just a heads up to anyone seeing this, 1.11.2 is now in public indigo according to http://www.ros.org/debbuild/indigo.html

fergs gravatar image fergs  ( 2014-05-26 09:04:22 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-05-22 20:23:21 -0600

Seen: 367 times

Last updated: May 24 '14