Ask Your Question
0

Hydro catkin_make error after update related to libflann

asked 2014-05-09 14:55:04 -0500

isura gravatar image

After upgrading the Hydro packages I get the following compile error:

make[2]: *** [  0%] No rule to make target `/usr/lib/libflann_cpp_s.a'
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-05-09 15:04:15 -0500

isura gravatar image

This seems to be related to libflann upgraded to 1.8.4-2. The solution was to downgrade libflann. I used aptitude to do this easily.

sudo aptitude remove libflann-dev

The first time aptitude suggests to remove many packages. Type 'n' for no at the prompt.

The second time aptitude suggests keeping libflann at 1.8.4-2. Type 'n' for no at the prompt.

The third time aptitude suggests downgrading libflann-dev [1.8.4-2 (now, precise) -> 1.7.1-1 (precise)]. Type 'y' for yes.

Here was my terminal output:

$ sudo aptitude remove libflann-dev
[sudo] password for isura: 
The following packages will be REMOVED:  
  libflann-dev libkms1{u} nvidia-settings-304{u} 
0 packages upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 11.1 MB will be freed.
The following packages have unmet dependencies:
 libpcl-search-1.7-dev : Depends: libflann-dev but it is not going to be installed.
 libpcl-kdtree-1.7-dev : Depends: libflann-dev but it is not going to be installed.
The following actions will resolve these dependencies:

      Remove the following packages:           
1)      libpcl-1.7-all                         
2)      libpcl-1.7-all-dev                     
3)      libpcl-apps-1.7-dev                    
.
.
.
80)     ros-hydro-turtlebot-simulator          
81)     ros-hydro-turtlebot-teleop             
82)     ros-hydro-turtlebot-viz                



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libflann-dev [1.8.4-2 (now, precise)]              



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

     Downgrade the following packages:                           
1)     libflann-dev [1.8.4-2 (now, precise) -> 1.7.1-1 (precise)]



Accept this solution? [Y/n/q/?] y
The following packages will be DOWNGRADED:
  libflann-dev 
The following packages will be REMOVED:
  libkms1{u} nvidia-settings-304{u} 
0 packages upgraded, 0 newly installed, 1 downgraded, 2 to remove and 0 not upgraded.
Need to get 0 B/892 kB of archives. After unpacking 2,039 kB will be freed.
Do you want to continue? [Y/n/?] y
(Reading database ... 496379 files and directories currently installed.)
Removing libkms1 ...
Removing nvidia-settings-304 ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
dpkg: warning: downgrading libflann-dev from 1.8.4-2 to 1.7.1-1.
(Reading database ... 496371 files and directories currently installed.)
Preparing to replace libflann-dev 1.8.4-2 (using .../libflann-dev_1.7.1-1_amd64.deb) ...
Unpacking replacement libflann-dev ...
Setting up libflann-dev (1.7.1-1) ...
edit flag offensive delete link more

Comments

If you don't have aptitude, install it: sudo apt-get install aptitude

isura gravatar image isura  ( 2014-05-09 15:05:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-09 14:55:04 -0500

Seen: 359 times

Last updated: May 09 '14