Ask Your Question
1

Turtlebot doesn't stop after killing the command velocity

asked 2014-05-02 12:43:19 -0500

Robert1 gravatar image

updated 2014-05-04 09:48:21 -0500

dornhege gravatar image

Hi Everyone, I am running two turtlebots (kobuki) with gazebo1.9 and I provided command velocities to each turtlebot using “rostopic pub” command. I noticed that turtlebot keep moving after I killed the command velocity using “Control tab +c”. I am wondering if this anomaly is due to the inertia values for my wheels or something else Thanks for any help with this issue

edit retag flag offensive close merge delete

Comments

Have faced similar problems with Roomba

Arkapravo gravatar imageArkapravo ( 2014-05-04 11:26:26 -0500 )edit
1

Somebody gave a tip to sent 0 command velocity. rostopic pub /cmd_vel geometry_msgs/Twist '[0.0, 0.0, 0.0]' '[0.0, 0.0, 0.0]' That command stopped the turtlebot.

Robert1 gravatar imageRobert1 ( 2014-05-05 05:36:12 -0500 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2014-05-05 16:44:36 -0500

I believe that unless a value of zero gets published, then the last value is what is used by the bot. Killing the publication command doesn't force a value of zero to be published, so the bot continues with the last speed it received.

edit flag offensive delete link more

Comments

I agree with you. I will take this for final answer

Robert1 gravatar imageRobert1 ( 2014-05-05 17:58:16 -0500 )edit
1

answered 2014-05-04 09:07:32 -0500

tfoote gravatar image

updated 2014-05-04 09:07:47 -0500

The gazebo plugin might not have a timeout on incoming commands when they stop being published it may continue to execute the last received command.

edit flag offensive delete link more

Comments

Hi Tfoote, In order to add a timeout on the incoming commands, Do i need to change the source code of the pluging? or is there another way to add a timeout? I installed Gazebo$gazebo-ros-pack from binaries and the turtlebot from source. For now, I send a 0 command velocity to stop the turtlebot. Thanks a lot for your help

Robert1 gravatar imageRobert1 ( 2014-05-05 05:42:03 -0500 )edit

You could look for a parameter that might enable this. If there isn't I'm sure a patch is appreciated.

dornhege gravatar imagedornhege ( 2014-05-05 06:32:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-02 12:43:19 -0500

Seen: 1,104 times

Last updated: May 05 '14