ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Unable to locate package, no valid OpenPGP data

asked 2014-04-26 16:44:29 -0500

robauto gravatar image

I am installing on Ubuntu trying to get through the steps and have tried to install on 2 different machines. When I try to install the certs using wget ( h t t p) // -o | sudo apt-key add - I get

no valid OpenPGP data found

When I try to install ros with sudo apt-get-install-ros-base i get:

E: Unable to locate ros-hydro-ros-base

I think everything else is configured. Anyone point me in the right direction here.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2014-04-26 20:19:11 -0500

ahendrix gravatar image

It sounds like you're having trouble adding the key for the ROS repositories. You may want to try downloading and adding the key in separate steps:

sudo apt-key add ros.key

Then you should be able to install ROS by running:

sudo apt-get update
sudo apt-get install ros-hydro-ros-base
edit flag offensive delete link more


Hi Ahendrix, I am also blocked by the same problem. I have tried what you proposed. Got the following result, felix@felix-notebook:~$ wget -o - | sudo apt-key add - gpg: no valid OpenPGP data found. felix@felix-notebook:~$ wget --2014-06-06 16:36:23-- Resolving ( Connecting to (||:80... connected. HTTP request sent, awaiting response... 200 OK Length: 1162 (1.1K) [application/pgp-keys] Saving to: `ros.key.4' 100%[======================================================================================================>] 1,162 --.-K/s in 0s 2014-06-06 16:36:23 (54.9 MB/s) - `ros.key.4' saved [1162/1162] felix@felix-notebook:~$ sudo apt-key add ros.key gpg: no valid OpenPGP data found. Appreciate it very much if you could give me any idea to solve this.

Felix gravatar image Felix  ( 2014-06-06 03:49:45 -0500 )edit

Sorry; you comment is completely unreadable without formatting. Can you please ask this as a new question?

ahendrix gravatar image ahendrix  ( 2014-06-06 11:20:02 -0500 )edit

Question Tools

1 follower


Asked: 2014-04-26 16:44:29 -0500

Seen: 6,787 times

Last updated: Apr 26 '14