Ask Your Question
0

tf:TransformTFToEigen() causes 'TransformTFToEigen' is not a member of 'tf'

asked 2014-04-20 22:11:47 -0500

zenifed gravatar image

While trying to build dvo_ros package for dense visual SLAM, i was given 'TransformTFToEigen' is not a member of 'tf' error for the line tf::TransformTFToEigen(tmp, result);

I have been trying to search around the documentations for tf package but could not find anything on the above function. Have the function been removed? If so was there a replace for the above function?

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
4

answered 2014-04-20 22:50:42 -0500

fergs gravatar image

This function is part of the "tf_conversions" package, specifically I think it is found in "tf_conversions/tf_eigen.h".

edit flag offensive delete link more

Comments

Thanks! I found it exactly where you have pointed me to. Hmm everything seems to be in order, what could have the cause of the error above.

zenifed gravatar imagezenifed ( 2014-04-21 17:52:26 -0500 )edit

Excuse me.I have met the same probelem as you.I want to know how you solve the problem.Thank you.

tcpu gravatar imagetcpu ( 2015-05-14 08:29:48 -0500 )edit

This error occurs when you do not have the above header included in your code.

tfoote gravatar imagetfoote ( 2015-05-14 12:33:18 -0500 )edit

I have met the same problem. The header file is included in the code. How can I solve this problem?

Soonhac gravatar imageSoonhac ( 2015-08-06 17:26:36 -0500 )edit
2

I solved this problem by replacing "TransformTFToEigen" and "TransformEigenToTF" with "transformTFToEigen" and "transformEigenToTF" respectively. Please see https://github.com/tum-vision/dvo/iss... .

Soonhac gravatar imageSoonhac ( 2015-08-12 13:26:07 -0500 )edit
2

answered 2016-03-17 22:43:11 -0500

sai gravatar image

Another possible solution from my experiments

Try transformEigenToTF (with the small t instead of capital T).

link: http://answers.ros.org/question/62436...

This change to convert to transformEigenToTF has solved the issue in my case. I am using ros indigo on 14.04

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-04-20 22:11:47 -0500

Seen: 1,865 times

Last updated: Mar 17 '16