Ask Your Question
0

roswtf says rosinstall missing

asked 2014-04-07 08:32:27 -0500

NLZ gravatar image

updated 2014-04-08 11:10:19 -0500

I started to go through the ROS tutorials and I reached roswtf. Now it says that it cant find the rosinstall python module, but it is installed. Not sure if I ever going to need rosinstall, but right now this warning just bothers me. Is it possible to know why roswtf says there is a problem? Or can I suppress the warning?

I'm running Ubuntu 12.04 with ROS Hydro.

viki@ubuntu:~/catkin_ws/devel$ roswtf
Loaded plugin tf.tfwtf
No package or stack in context
================================================================================
Static checks summary:

Found 1 warning(s).
Warnings are things that may be just fine, but are sometimes at fault

WARNING You are missing core ROS Python modules: rosinstall -- 

================================================================================

ROS Master does not appear to be running.
Online graph checks will not be run.
ROS_MASTER_URI is [htp://localhost:11311]

.

viki@ubuntu:~/catkin_ws/devel$ dpkg --get-selections | grep rosinstall
python-rosinstall               install

viki@ubuntu:~$ which rosinstall 
/usr/local/bin/rosinstall

I even tried apt-get reinstall and purge remove and install, but no avail.

I installed rosinstall_shellcompletion with pip, maybe that caused some nasty stuff under the roof.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2014-04-07 14:40:01 -0500

jbinney gravatar image

You can fix this by running

sudo apt-get install python-rosinstall
But unless you need rosinstall, it shouldn't be a problem.

edit flag offensive delete link more

Comments

Sorry I didnt made it more visible, but at the end of the code you can see that "dpkg --get-selections | grep rosinstall" returned with python-rosinstall installed. And apt-get install returns that "python-rosinstall is already the newest version."

NLZ gravatar image NLZ  ( 2014-04-08 03:22:44 -0500 )edit

Just to be sure I did a "sudo apt-get install --reinstall python-rosinstall" but the problem still stands. I even tried sudo apt-get remove --purge python-rosinstall sudo apt-get clean sudo apt-get install python-rosinstall But roswtf still thinks its missing.

NLZ gravatar image NLZ  ( 2014-04-08 03:30:47 -0500 )edit

Oops, missed that. If you run "which rosinstall" does it actually exist?

jbinney gravatar image jbinney  ( 2014-04-08 09:47:22 -0500 )edit

It says /usr/local/bin/rosinstall

NLZ gravatar image NLZ  ( 2014-04-08 10:05:57 -0500 )edit

It sounds like you have rosinstall installed through pip; try running `sudo pip uninstall rosinstall` REPREATEDLY until it tells you that rosinstall is not installed.

ahendrix gravatar image ahendrix  ( 2014-04-08 10:20:48 -0500 )edit

I installed rosinstall_shellcompletion with pip, but pip uninstalling both (after apt-get remove) and reinstalling rosinstall with apt-get did not changed the error.

NLZ gravatar image NLZ  ( 2014-04-08 11:06:45 -0500 )edit
1

That's weird. If you installed rosinstall correctly (using apt-get), it should be in /usr/bin, not /usr/local/bin.

Martin Günther gravatar image Martin Günther  ( 2014-04-10 01:42:34 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-04-07 08:32:27 -0500

Seen: 568 times

Last updated: Apr 08 '14