ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

problems when running catkin_create_pkg

asked 2014-04-04 05:32:29 -0500

jesperhn gravatar image

Hello,

I am currently trying to install ROS, and getting to know the environment by following the well written online tutorials.

First I did a complete new ROS install on my Ubuntu 12.04, by following the install instructions here: wiki.ros.org/hydro/Installation/Ubuntu

After this I dug right into the tutorials wiki.ros.org/ROS/Tutorials

But on the 3. tutorial, wiki.ros.org/ROS/Tutorials/CreatingPackage, I am currently stuck, since I get an error when running catkin_create_pkg. It output this to my shell:

File "/usr/local/bin/catkin_create_pkg", line 4, in <module>
import pkg_resources
File "/usr/local/lib/python2.7/dist-packages/distribute-0.6.28-py2.7.egg/pkg_resources.py", line 2819, in <module>
parse_requirements(__requires__), Environment()
File "/usr/local/lib/python2.7/dist-packages/distribute-0.6.28-py2.7.egg/pkg_resources.py", line 588, in resolve
raise DistributionNotFound(req)

I have already tried different things, like reinstalling the whole ROS, tryign to reinstall the python-catkin-pkg, and bunch of other things. Tried to follow the tutorials from scratch several times, to ensure I wasnt missing something. Read some forums, and can already give some details about the installation:

python -c 'import catkin_pkg; print(catkin_pkg.__file__)'

gives

/usr/share/pyshared/catkin_pkg/__init__.py

Anyone got any clue of how I can fix this error, or maybe where to look? Any help would be greatly appreciated.

edit retag flag offensive close merge delete

Comments

1

The /usr/local/... path is somewhat suspicious. For me catkin resides in /usr/bin. Do you have an older manual catkin install from somewhere?

dornhege gravatar image dornhege  ( 2014-04-04 05:49:53 -0500 )edit

Had ROS groovy installed last year on this machine, maybe that could cause it?

jesperhn gravatar image jesperhn  ( 2014-04-07 00:14:01 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-04-07 01:21:30 -0500

jesperhn gravatar image

updated 2014-04-07 01:21:51 -0500

Fixed it! Somehow an "EASY-INSTALL-SCRIPT" had put a catkin_create_pkg under /usr/local/bin which was messing with the actual catkin_create_pkg script. Removed the wrong script (which btw had no actual content), and it worked perfect afterwards!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-04 05:32:29 -0500

Seen: 224 times

Last updated: Apr 07 '14