ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
0

apt-get doesn't find ROS packages at all

asked 2015-11-18 14:24:07 -0600

Tetrachromat gravatar image

I've tried running sudo apt-get install ros-indigo-ros-tutorials ros-indigo-geometry-tutorials ros-indigo-rviz ros-indigo-rosbash ros-indigo-rqt-tf-tree but it outputs:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-indigo-ros-tutorials
E: Unable to locate package ros-indigo-geometry-tutorials
E: Unable to locate package ros-indigo-rviz
E: Unable to locate package ros-indigo-rosbash
E: Unable to locate package ros-indigo-rqt-tf-tree

apt-get seems to be able to download other things such as nmap but the ROS packages simply are un-locatable. Any ideas? I'm pretty new to Raspbian (I'm on a RPi) and feel a bit at a loss.

Thanks!

edit retag flag offensive close merge delete

Comments

did you run sudo apt-get update beforehand?

Dimitri Schachmann gravatar imageDimitri Schachmann ( 2015-11-18 15:43:51 -0600 )edit

Yes. I did it, but no luck.

Tetrachromat gravatar imageTetrachromat ( 2015-11-18 16:47:45 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-11-18 15:46:08 -0600

ahendrix gravatar image

The Raspberry Pi does not use the same binary format as standard desktop computers, so the standard ROS installation setup does not work.

Have a look at the ROS Indigo on Raspberry Pi instructions.

If you're using a Raspberry Pi 2, you can also install Ubuntu on it, and use the Ubuntu for armhf instructions: http://wiki.ros.org/indigo/Installati...

edit flag offensive delete link more

Comments

I did run the setup from that installation page. Roscore does actually run, but specifically there's a problem downloading packages.

Tetrachromat gravatar imageTetrachromat ( 2015-11-18 16:48:51 -0600 )edit

Which installation page? I linked to two.

ahendrix gravatar imageahendrix ( 2015-11-18 18:53:04 -0600 )edit

First link.

Tetrachromat gravatar imageTetrachromat ( 2015-11-18 20:02:56 -0600 )edit

The first link describes an installation of ROS from sources, and the final section (5.2) describes how to add additional packages from source. You can't use apt-get to add packages to a source install, and the apt packages aren't available on Raspbian.

ahendrix gravatar imageahendrix ( 2015-11-18 22:28:51 -0600 )edit

Have you had any luck with this? I have been having the same issue for several days now. This is the first part of the tutorial that hasn't worked. Can we just download each package from the source instead?

LukeH gravatar imageLukeH ( 2016-01-20 08:33:05 -0600 )edit

@LukeH: the answer is pretty clear - if you're following the from-source installation on the Raspberry Pi, you can't use apt to install additional packages. Use the instructions in section 5.2 for installing additional packages from source.

ahendrix gravatar imageahendrix ( 2016-01-20 11:38:24 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-18 14:24:07 -0600

Seen: 1,650 times

Last updated: Nov 18 '15