Ask Your Question
0

Unable to integrate with Qt.

asked 2014-04-04 00:49:07 -0500

DPK27 gravatar image

updated 2014-04-04 00:50:10 -0500

I am trying to implement Grid based FAST SLAM in ROS. I have taken the source code from http://openslam.org/gridslam.html .

I have made a catkin package and put all the source code in src folder. Now, I am trying to build that package using $catkin_make

It is giving me the error: qapplication.h No such file or directory.

I have qt4 installed already and have qapplication.h file at /usr/include/qt4/Qt

I have tried using .pro file and qmake but still its giving me the error. what should I do please help...

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2014-04-04 08:23:07 -0500

Hamid Didari gravatar image

write the following lines in your Cmake

find_package(Qt4 COMPONENTS QtCore QtGui)
INCLUDE(${QT_USE_FILE})
ADD_DEFINITIONS(${QT_DEFINITIONS})
rosbuild_add_executable(qt_test src/qt_test.cpp)
target_link_libraries(qt_test ${QT_LIBRARIES})

also please see this question

edit flag offensive delete link more

Comments

but instead of rosbuild_add_executable(qt_test src/qt_test.cpp) add_executable(qt_test src/qt_test.cpp) worked for me.. Thanx :)

DPK27 gravatar image DPK27  ( 2014-04-05 23:29:04 -0500 )edit

rosbuild_add_executable for rosbuild system and add_executable for catkin. I made mistake that I thought you worked with rosbuild system...

Hamid Didari gravatar image Hamid Didari  ( 2014-04-06 02:27:36 -0500 )edit
1

answered 2014-04-04 01:47:49 -0500

demmeln gravatar image

I would start by googling about using Qt in catkin. For exmaple this turns up (have not checked if it is good): https://qt-project.org/quarterly/view...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-04 00:49:07 -0500

Seen: 485 times

Last updated: Apr 04 '14