Ask Your Question
0

Roscore is not running

asked 2014-04-03 20:33:54 -0500

jennifer gravatar image

updated 2014-04-03 21:10:54 -0500

130s gravatar image

I get the following error when I run roscore:

Traceback (most recent call last):
  File "/opt/ros/hydro/bin/roscore", line 62, in <module>
    import roslaunch
  File "/opt/ros/hydro/lib/python2.7/dist-packages/roslaunch/__init__.py", line 46, in <module>
    import rospkg
ImportError: No module named rospkg

I have installed fuerte and now have installed hydro side by side...

edit retag flag offensive close merge delete

Comments

yes I tried almost all of them.. Still not able to get the answer... Any guesses what it could be?

jennifer gravatar image jennifer  ( 2014-04-07 09:36:04 -0500 )edit

did u solve it ?? I have the same problem :S

RSA_kustar gravatar image RSA_kustar  ( 2014-09-21 10:13:11 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-11-12 11:00:02 -0500

jennifer gravatar image

updated 2014-11-13 08:56:15 -0500

Thanks people... The problem was ros hydro python path was the problem.. Set your python path correctly as ros hydro relies a lot on python. I didnt have problem with fuerte... However hydro has

edit flag offensive delete link more
3

answered 2014-04-03 21:18:01 -0500

130s gravatar image

Google returns a few threads about the same/similar issues. I'd suggest you might want to check the answers suggested in some of those first.

edit flag offensive delete link more
1

answered 2015-09-08 02:39:05 -0500

AldurDisciple gravatar image

For the record, I had the same problem with WinROS hydro, and I was missing some Python dependencies : SetupTools-0.6c11 and WinROS-python-build-tools.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-03 20:33:54 -0500

Seen: 913 times

Last updated: Sep 08 '15