Ask Your Question
0

Problem with roscore

asked 2016-04-28 18:25:17 -0500

LogicRos gravatar image

updated 2016-04-29 15:01:52 -0500

Hello all!

I have a new problem, now when I want to run roscore shows the fallowing.

The OS that I'm using is Raspbian with ROS Indigo

process[master]: started with pid [2464]
ROS_MASTER_URI=http://cctronics:11311/

started core service [/rosout]
/opt/ros/indigo/lib/rosout/rosout: error while loading shared libraries: libboost_thread.so.1.54.0: cannot open shared object file: No such file or directory
[rosout-1] process has died [pid 2477, exit code 127, cmd /opt/ros/indigo/lib/rosout/rosout __name:=rosout __log:=/home/pi/.ros/log/6fe27282-341b-11e5-a82f-b827eb1d4855/rosout-1.log].
log file: /home/pi/.ros/log/6fe27282-341b-11e5-a82f-b827eb1d4855/rosout-1*.log

image description

After of run the fallowing line.

pi@cctronics ~ $ sudo apt-get install libboost-thread1.54.0


pi@cctronics ~ $ sudo apt-get install libboost-thread1.54.0
Reading package lists... Done
Reading state information... Done
Package libboost-thread1.54.0 is not available, but is referred to by another packages.
This may mean that the package is missing, has been obsoleted, or is only avalilable from another source.
E: Package 'libboost-thread1.54.0' has no installation candidate
edit retag flag offensive close merge delete

Comments

1

It looks like there's something wrong with your ROS installation or your system libraries. It would be useful to know which OS you're using, which version of ROS you're using, and a link to the install instructions you followed when installing ROS.

ahendrix gravatar imageahendrix ( 2016-04-28 19:39:40 -0500 )edit

Hello. The OS that I'm using is Raspbian with ROS Indigo, and when I bought RPi already had the OS loaded. http://www.moosth.net/calabrothers/?p...

What do you recommend me?

LogicRos gravatar imageLogicRos ( 2016-04-29 10:21:01 -0500 )edit

It looks like ROS isn't installed correctly, or some of the dependencies are missing. Have you made any changes (particularly with dpkg or apt-get) since you got it?

ahendrix gravatar imageahendrix ( 2016-04-29 11:14:49 -0500 )edit

Interestingly, this is an issue with the same version of boost that you reported here: http://answers.ros.org/question/23176... . I suspect these are related.

ahendrix gravatar imageahendrix ( 2016-04-29 11:15:53 -0500 )edit

Of course, I wrote that question. But proposed solutions did not work. Even I have that problem. Try to install dependencies from this website http://packages.ros.org/ros-shadow-fi... using dpkg -i

LogicRos gravatar imageLogicRos ( 2016-04-29 11:57:12 -0500 )edit

Ok. it would have been good to give feedback on the original question indicating that the proposed solutions didn't work, and the error message involved.

ahendrix gravatar imageahendrix ( 2016-04-29 12:02:36 -0500 )edit

I ran the line that you give me, and I edited my question with the result

LogicRos gravatar imageLogicRos ( 2016-04-29 14:43:08 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-04-29 12:06:37 -0500

ahendrix gravatar image

updated 2016-04-29 15:07:21 -0500

The libboost_thread library, version 1.54.0 is missing from your system.

This might be an error in the original OS image, or it might be that you removed or upgraded libboost_thread.

I would start attempting to solve this by running:

sudo apt-get install libboost-thread1.54.0

If that results in an error, please EDIT your question with the TEXT of the command output. Please don't take a screenshot, because screenshots are not searchable

UPDATE

It looks like you don't have your apt repositories set up correctly. Have you enabled the main, universe, multiverse and restricted repositories as recommended in the UbuntuARM install guide? You can follow the instructions here for enabling repositories.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-28 18:25:17 -0500

Seen: 881 times

Last updated: Apr 29 '16