ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

PCL Kdtree symbol lookup error running program from terminal

asked 2014-04-03 07:48:06 -0500

Gop gravatar image

I'm JUST TRYING to run the icp Demo available in the pcl tutorials

I can compile it perfectly... the problem is when i try to run the program in the terminal I get this :

./interactive_icp: symbol lookup error: ./interactive_icp: undefined symbol: _ZN3pcl6search6KdTreeINS_8PointXYZEEC1Eb

And Yes, I've already tried this :

sudo apt-get install -f and

sudo apt-get autoremove together with erasing build dirs and rebuilding in my workspace

rm -r devel rm -r build ...

but it still doesn't work... Can you please help me ? It's been a week and a half all around this and its getting really frustrating since I just want to see the demo running !

I'm running pcl 1.7 with QT creator on Ubuntu 12.04 LTS.

THANK YOU ALL for your time !!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2014-04-04 00:05:32 -0500

demmeln gravatar image

Ok, first make sure all ros packges are upgraded. Call apt-get update and apt-get upgrade. If there are any ros-... packages "kept back", then try again with apt-get distupgrade or pick them out manually.

After that, rebuild your compelte workspace. As you have shown, it is best to remove devel/build/install. If this doesn't bring success, rinse and repeat, but this time execute the following two commands in order (call catkin_make with your parameters) and post the compelte output of both as an edit to your question (its probably best to put them on or and put the link in your question).

$ env | grep -i ROS
$ catkin_make [...]
edit flag offensive delete link more

answered 2014-04-05 04:44:04 -0500

Gop gravatar image

First of all thank you for your input demmeln ! Before I tried your answer I reinstalled my ubuntu OS ( again with 12.04 LTS ), and after installing pcl and qt, I was able to run the demos and project i had with errors without any problems! So, concluding, the problem was in my ubuntu installation probably !

Thank you all for your time ! Regards !

edit flag offensive delete link more


You're welcome :)

demmeln gravatar image demmeln  ( 2014-04-06 02:39:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2014-04-03 07:48:06 -0500

Seen: 659 times

Last updated: Apr 05 '14