ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

failure in rosmaking files

asked 2014-04-02 17:19:50 -0500

danmianjing_00 gravatar image

updated 2014-04-03 05:05:29 -0500

demmeln gravatar image

when I rosmake any file ,it has error and warning,like: rosmake arbotix, the results are as follows,

[ rosmake ] rosmake starting...                                                 
[ rosmake ] Packages requested are: ['arbotix']                                 
[ rosmake ] Logging to directory /home/yanglan/.ros/rosmake/rosmake_output-20140403-111529
[ rosmake ] Expanded args ['arbotix'] to:
[ rosmake ] WARNING: The following args could not be parsed as stacks or packages: ['arbotix']
[ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

then I can not launch the note. what can I do to solve it ,thank you!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2014-04-03 05:07:30 -0500

demmeln gravatar image

updated 2014-04-04 01:22:40 -0500

rosmake does not find your package arbotix, which indicates that you have not set up your environment properly.

Which version of ROS are you using and where is the arbotix package located? How did your get the code? (Edit your question to include all this information).

Edit: I'm pretty sure you have not set up your environemnt successfully if rosmake does not find the package arbotix.

You will want to have something like the following lines in your .bashrc:

source /opt/ros/groovy/setup.bash
edit flag offensive delete link more


I'm using groovy on ubuntu 12.04,I get the code through svn checkout, and it is located in the home folder. I have set up my environment successfully.

danmianjing_00 gravatar image danmianjing_00  ( 2014-04-03 15:53:34 -0500 )edit

Hello,demmeln ,when I want to rosmake files ,I must run the two cmmands you refered above before rosmaking files , if not ,I would get errors like that ,this would be a little troublesome I think,how could I do to solve it permanently? Thank you!

danmianjing_00 gravatar image danmianjing_00  ( 2014-04-14 21:47:33 -0500 )edit

You can add them to your .bashrc file so that they get executed automatically every time you open a terminal.

demmeln gravatar image demmeln  ( 2014-04-15 06:05:19 -0500 )edit

Question Tools

1 follower


Asked: 2014-04-02 17:19:50 -0500

Seen: 237 times

Last updated: Apr 04 '14