Ask Your Question
0

Can't build the face recognition package

asked 2014-03-31 23:45:38 -0500

RosFaceNoob gravatar image

updated 2016-10-24 08:59:01 -0500

ngrennan gravatar image

Hi, I got face recognition tutorial on ros wiki page:

www.ros.org/wiki/face_recognition

but i can't build it. I tried to build the workspace using catkin_make and rosmake. I use the command "catkin-make" in the face_recognition workaspace but it already contains a CMakeLists.txt so the command doesn't work. I also tried the "rosmake face_recognition" but I have this error "ERROR: No arguments could be parsed into valid package or stack names." despite the fact that there is a "stack.xml" file in the folder.

Can somebody help me please? Thank you

edit retag flag offensive close merge delete

Comments

Please edit your question to include more information, like the exact commands you are executing and the full output you are getting.

demmeln gravatar image demmeln  ( 2014-04-01 00:18:08 -0500 )edit

Sorry. I edit the question.

RosFaceNoob gravatar image RosFaceNoob  ( 2014-04-01 02:31:10 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-04-01 02:48:57 -0500

demmeln gravatar image

updated 2014-04-01 03:37:41 -0500

This is a rosbuild/rosmake package, so don't try to build it with catkin. The code hasn't been touched for the last two years it seems, so not sure if you can make it work easily.

Please make sure the stack is contained in your ROS_PACKAGE_PATH environment variable.

What does env | grep -i ROS output?

Edit:

To add your folder to ROS_PACKAGE_PATH, you need to exectue export ROS_PACKAGE_PATH=/path/to/your/folder/containing/face/recognition:$ROS_PACKAGE_PATH after the source /opt/ros/hydro/setup.bash command. You can either do this directly in the terminal, or add it to your .bashrc file.

edit flag offensive delete link more

Comments

The output is : ROS_ROOT=/opt/ros/hydro/share/ros ROS_PACKAGE_PATH=/opt/ros/hydro/share:/opt/ros/hydro/stacks ROS_MASTER_URI=http://localhost:11311 LD_LIBRARY_PATH=/opt/ros/hydro/lib CPATH=/opt/ros/hydro/include PATH=/opt/ros/hydro/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games PWD=/opt/ros/hydro/lib/gscam ROSLISP_PACKAGE_DIRECTORIES= ROS_DISTRO=hydro PYTHONPATH=/opt/ros/hydro/lib/python2.7/dist-packages PKG_CONFIG_PATH=/opt/ros/hydro/lib/pkgconfig CMAKE_PREFIX_PATH=/opt/ros/hydro ROS_ETC_DIR=/opt/ros/hydro/etc/ros OLDPWD=/opt/ros/hydro The stack is not in my ROS_PACKAGE_PATH. How can I add it?

RosFaceNoob gravatar image RosFaceNoob  ( 2014-04-01 03:13:57 -0500 )edit

Thank you, It works. But if I do a "source /opt/ros/hydro/setup.bash", the path is cleaned so I have to do it again. Is there a way to change definitly the path?

RosFaceNoob gravatar image RosFaceNoob  ( 2014-04-01 03:59:28 -0500 )edit

put both commands in your `.bashrc`

demmeln gravatar image demmeln  ( 2014-04-01 04:26:52 -0500 )edit

I add those lines to my '.bashrc' but it doesn't work. "source /opt/ros/hydro/setup.bash export ROS_PACKAGE_PATH=~/procrob_functional-master:$ROS_PACKAGE_PATH"

RosFaceNoob gravatar image RosFaceNoob  ( 2014-04-01 04:48:14 -0500 )edit

Have you opened a fresh terminal afterwards?

demmeln gravatar image demmeln  ( 2014-04-01 11:40:36 -0500 )edit

I just forgot to source the file before testing. It's fine now

RosFaceNoob gravatar image RosFaceNoob  ( 2014-04-01 21:24:32 -0500 )edit
1

answered 2014-11-12 06:27:16 -0500

Pouyan gravatar image

The catkin version of the face_recognition package has been released. Please see http://wiki.ros.org/face_recognition

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-03-31 23:45:38 -0500

Seen: 441 times

Last updated: Nov 12 '14