ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

rviz doesn't launch --> core dumped [closed]

asked 2014-03-27 16:47:24 -0600

Warrior gravatar image

Hi everyone,

When I execute the command line "rosrun rviz rviz -d rospack find stage_ros/rviz/stage.rviz" I get the following error:

OpenGL Warning: No pincher, please call crStateSetCurrentPointers() in your SPU
Segmentation fault (core dumped)

I may note that I am using the Hydro distribution on a Ubuntu 12.04 on VirtualBox with 3D hardware acceleration enabled, but it seems that still there is a problem with graphics ... . I haven't been able to find any solution to the problem by surfing on the Internet. I really need your help as I'm doing a project and I'm stuck badly. How can I solve this error?

Thank you

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by demmeln
close date 2014-03-29 10:57:27

2 Answers

Sort by ยป oldest newest most voted

answered 2014-03-29 08:25:21 -0600

Warrior gravatar image

Hi everyone,

I had to install Ubuntu besides Windows. As far as I found out, for new graphic cards VirtualBox does not offer good 3D hardware acceleration service! So, I had to install Ubuntu. The problem is solved and rviz runs smoothly.

edit flag offensive delete link more

answered 2014-03-27 18:35:24 -0600

nanaky gravatar image

It doesn't look like a ROS problem, it's a VirtualBox problem I believe.

Which version of VirtualBox are you using? Maybe you should update to the latest.

edit flag offensive delete link more


I'm using v. 4.3.6. I am going to update it to the latest.

Warrior gravatar image Warrior  ( 2014-03-28 03:20:42 -0600 )edit

The problem still persists :(

Warrior gravatar image Warrior  ( 2014-03-28 03:39:32 -0600 )edit

Try deselecting the 3D accelerator box in Display in the VBox Manager.

nanaky gravatar image nanaky  ( 2014-03-28 12:53:42 -0600 )edit

Yes, exactly go to the virtual machine settings in your VirtualBox control panel and deselect the "Enable 3D acceleration"

angelos.p gravatar image angelos.p  ( 2017-06-07 03:40:31 -0600 )edit

Question Tools

1 follower


Asked: 2014-03-27 16:47:24 -0600

Seen: 991 times

Last updated: Mar 29 '14