Ask Your Question
0

Hydro for Ubuntu Precise armhf on new kernel

asked 2014-03-17 23:14:45 -0500

hvn gravatar image

Hi,

I'm intending to test the following: run Ubuntu Precise armhf with ROS Hydro with kernel 3.10. Having read that Hydro is supported up to Raring (kernel 3.8), I think that my combination will result in a non-working situation. Any suggestions ?

Thanks

edit retag flag offensive close merge delete

Comments

Ok, just did this and roscore (hydro) reports that it's "unable to contact my own server at [http://<server>:59299]".

hvn gravatar imagehvn ( 2014-03-18 01:31:31 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-03-18 05:43:36 -0500

ahendrix gravatar image

My first assumption here is that this should work. ROS depends very strongly on libraries such as boost, and really don't care which kernel it's running on top of. In fact, most of Ubuntu cares very little about the kernel.

The error you're seeing about "cannot contact my own master" is a network/loopback configuration issue and not related to the kernel. Try pinging your machine's hostname to confirm, then try adding your hostname to one of the loopback addresses in /etc/hosts

edit flag offensive delete link more

Comments

My hostname is added to /etc/hosts. The ping is successful, although it delivers only 1 ping. After this it does nothing but hanging in there: 64 bytes from <server> (127.0.1.1): icmp_req=1 ttl=64 time=0.135 ms ^C --- <server> ping statistics --- 1 packets transmitted, 1 received, 0% packet loss, time 0ms rtt min/avg/max/mdev = 0.135/0.135/0.135/0.000 ms The ^C is given by me after waiting more than 5 minutes. What about the server address? When I ran Groovy, the address was 11311, now it is 59299. Is this usual ?

hvn gravatar imagehvn ( 2014-03-18 21:10:04 -0500 )edit

Tested roscore/ping localhost again. Via ssh, it only pings once which is successful. Direct on system in X terminal, ping goes fine. Via ssh, roscore starts but after message "Usage < 1GB" nothing. Only way to stop = kill PID. Via X terminal, after long wait it again "cannot contact own server".

hvn gravatar imagehvn ( 2014-03-18 23:44:39 -0500 )edit

It sounds like you have some network driver or network setup problems on you machine. You'll have to get those sorted out before anything that depends on networking (including ROS) will work.

ahendrix gravatar imageahendrix ( 2014-03-19 08:20:19 -0500 )edit

which python version goes with either groovy or hydro ? The running version is 2.7.3

hvn gravatar imagehvn ( 2014-03-20 06:16:35 -0500 )edit

Python 2.7.3 is fine.

ahendrix gravatar imageahendrix ( 2014-03-20 08:04:29 -0500 )edit

As a side note, roscore should be starting up on port 11311; not 59299. Are you sure you have your ROS_MASTER_URI set correctly?

ahendrix gravatar imageahendrix ( 2014-03-20 12:13:21 -0500 )edit

Yes, the port number is what I was wondering about as well. Was used to 11311. Good question..will look at that.

hvn gravatar imagehvn ( 2014-03-20 12:35:38 -0500 )edit

Tried the same combination (kernel 3.10.18 and hydro) on an x86 (actually old AthlonXP). No problem, either with or without real-time (xenomai). Standard installation Ubuntu 12.04. On armhf still a no go.

hvn gravatar imagehvn ( 2014-03-26 06:32:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-03-17 23:14:45 -0500

Seen: 125 times

Last updated: Mar 18 '14