Hydro Build Issue on Ubuntu 13.10 [closed]

asked 2014-03-10 08:33:26 -0500

nckswt gravatar image

updated 2014-03-10 08:48:29 -0500

Following the Hydro install from source guide, everything works fine (barring the Gazebo2 install) until I get to the build stage. When I run $ ./src/catkin/bin/catkin_make_isolated --install I get the following error:

 Processing catkin package: 'catkin'
 ==> cmake /home/nick/ros_catkin_ws/src/catkin -     
 DCATKIN_DEVEL_PREFIX=/home/nick/ros_catkin_ws/devel_isolated/catkin -     
 DCMAKE_INSTALL_PREFIX=/home/nick/ros_catkin_ws/install_isolated in '/home/nick/ros_catkin_ws/build_isolated/catkin'
 Unhandled exception of type 'OSError':
 Traceback (most recent call last):
   File "./src/catkin/bin/../python/catkin/builder.py", line 832, in build_workspace_isolated
number=index + 1, of=len(ordered_packages)
   File "./src/catkin/bin/../python/catkin/builder.py", line 585, in build_package
   File "./src/catkin/bin/../python/catkin/builder.py", line 350, in build_catkin_package
run_command_colorized(cmake_cmd, build_dir, quiet, add_env=add_env)
   File "./src/catkin/bin/../python/catkin/builder.py", line 170, in run_command_colorized
run_command(cmd, cwd, quiet=quiet, colorize=True, add_env=add_env)
   File "./src/catkin/bin/../python/catkin/builder.py", line 188, in run_command
raise OSError("Failed command '%s': %s" % (cmd, e))
 OSError: Failed command '['cmake', '/home/nick/ros_catkin_ws/src/catkin', '-DCATKIN_DEVEL_PREFIX=/home/nick/ros_catkin_ws/devel_isolated/catkin', '-DCMAKE_INSTALL_PREFIX=/home/nick/ros_catkin_ws/install_isolated']': [Errno 2] No such file or directory
 <== Failed to process package 'catkin': 
   Failed command '['cmake', '/home/nick/ros_catkin_ws/src/catkin', '-DCATKIN_DEVEL_PREFIX=/home/nick/ros_catkin_ws/devel_isolated/catkin', '-DCMAKE_INSTALL_PREFIX=/home/nick/ros_catkin_ws/install_isolated']': [Errno 2] No such file or directory
 Command failed, exiting.

It seems like catkin isn't able to create the directory structure and the makefiles needed for cmake. Any idea what might be going on?

Edit: I'm running Ubuntu 13.10 because I'm on a new Retina MacBook pro, and 13.04 doesn't play nicely with the Haswell CPU.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2018-01-30 17:37:30.731834



Do you have `cmake` installed?

William gravatar image William  ( 2014-03-10 09:19:13 -0500 )edit

I get the same error. Did you fix it?

sixm gravatar image sixm  ( 2015-11-13 22:50:23 -0500 )edit