rosbridge - How to run example in hydro [closed]

asked 2014-03-04 10:39:17 -0600

Bastbeat gravatar image

updated 2014-03-04 20:49:14 -0600

I need to use rosbridge. But when I install the version for hydro, I can not run the example "roslibjs/Tutorials/BasicRosFunctionality" I tried to run "rostopic pub /listener std_msgs/String "Hello, World"". But there isn´t a node /listener to run Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Bastbeat
close date 2014-04-10 06:31:57


Which version of rosbridge are you running? Can you add the exact command you're running and the error you're receiving to your question?

ahendrix gravatar image ahendrix  ( 2014-03-04 10:54:51 -0600 )edit

I´m running the version rosbridge 2.0 (hydro version) Sorry, but I did´nt explain correctly my problem. "roslibjs/Tutorials/BasicRosFunctionality" That´s the example that I can not run. this command: rostopic pub /listener std_msgs/String "Hello, World" There is not any node listener running.

Bastbeat gravatar image Bastbeat  ( 2014-03-04 20:44:22 -0600 )edit

I'm not sure what you mean by "there isn't a node /listener to run". I have no trouble running that command on my computer.

ahendrix gravatar image ahendrix  ( 2014-03-04 21:04:17 -0600 )edit

Ok, I solved it. It was only a problem of distros. Thank you!

Bastbeat gravatar image Bastbeat  ( 2014-03-04 21:26:54 -0600 )edit

Can you write up your solution as an answer, to help the next person who has this problem?

ahendrix gravatar image ahendrix  ( 2014-03-05 08:23:29 -0600 )edit

I had installed 2 distros, groovy and hydro. and I had 2 workspaces. The problem: I was loging in in the incorrect workspace(groovy)

Bastbeat gravatar image Bastbeat  ( 2014-04-06 23:40:05 -0600 )edit