Ask Your Question
0

problems with naoqi after compille workstation compile_error [closed]

asked 2014-03-03 06:50:04 -0500

Dante gravatar image

updated 2016-10-24 08:36:01 -0500

ngrennan gravatar image

hi,

when i compiling my workspace, i get this error:

-- nao_msgs: 48 messages, 5 services -- +++ processing catkin package: 'nao_driver' -- ==> add_subdirectory(nao_robot/nao_driver)

-- Could not find NAOqi's alcommon

-- Could not find NAOqi's alvision

-- Could not find NAOqi's alproxies

-- Could not find NAOqi's alerror

-- Could not find NAOqi's alvalue

-- Cannot find NAOqi C++ sdk; C++ nodes will NOT be built

In my .bashrc i edit the line:

export $PYTHONPATH="$PYTHONPATH:$HOME/workspace/ros/groovy/src/pynaoqi-sdk-1.14-linux64bits/pynaoqi/"

how i edit the c++ sdk to the .bashrc?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by Dante
close date 2014-03-14 03:49:51

Comments

I'm not sure what this has to do with roscore; you may get better responses with a better question title.

ahendrix gravatar image ahendrix  ( 2014-03-04 04:30:03 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-03-04 21:20:55 -0500

Dante gravatar image

updated 2014-03-06 02:54:03 -0500

problem solved

edit flag offensive delete link more

Comments

Can you document how you solved this, to help the next person who has the same problem?

ahendrix gravatar image ahendrix  ( 2014-03-06 05:35:05 -0500 )edit

download with git clone nao_robot und humanoid messages, not nao extras and then you can compile your workstation. In the .bashrc have to be the file in which python naoqi and c++ naoqi is. export PYTHONPATH=$HOME/workspace/ros/groovy/src/naoqi/lib:$PYTHONPATH export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$HOME/workspace/ros/groovy/src/naoqi/lib This works for me

Dante gravatar image Dante  ( 2014-03-14 03:48:53 -0500 )edit
0

answered 2014-03-04 04:32:09 -0500

ahendrix gravatar image

It looks like CMake can't find the Nao SDK. The usual solution to this is to add it to your CMAKE_PREFIX_PATH . I'm not familiar enough with the Nao to suggest a more specific fix.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-03-03 06:50:04 -0500

Seen: 360 times

Last updated: Mar 06 '14